Bug 141503 - xmodmap segfault
xmodmap segfault
Status: CLOSED DUPLICATE of bug 138458
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-01 12:46 EST by dann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description dann 2004-12-01 12:46:45 EST
Description of problem:
I have had the following in my ~/.Xmodmap for a long time, it 
is used to turn Caps Lock 


remove Lock = Caps_Lock
keysym Caps_Lock = Control_L
add Control = Control_L

Version-Release number of selected component (if applicable):
xorg-x11-6.8.1-12.FC3.1

How reproducible:
Put the 3 lines above in ~/.Xmodmap 
and run in a shell: 
xmodmap ~/.Xmodmap

You will get a segmentation fault. 

This used to work
Comment 1 Mike A. Harris 2004-12-07 02:45:49 EST

*** This bug has been marked as a duplicate of 138458 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:07:25 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.