Bug 1415226 - packaging: python/python2(/python3) cleanup
Summary: packaging: python/python2(/python3) cleanup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: packaging
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Niels de Vos
QA Contact:
URL:
Whiteboard:
Depends On: 1414902
Blocks: glusterfs-3.10.0
TreeView+ depends on / blocked
 
Reported: 2017-01-20 15:37 UTC by Kaleb KEITHLEY
Modified: 2017-03-06 17:44 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1414902
Environment:
Last Closed: 2017-02-27 15:30:22 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2017-01-20 15:37:47 UTC
+++ This bug was initially created as a clone of Bug #1414902 +++

Description of problem:

Spec file needs to be updated to current python2 (vs. python3) guidelines.

While doing package review of new python-glusterfs-api we were reminded that we should update the glusterfs.spec(.in) accordingly.

Version-Release number of selected component (if applicable):

all

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Worker Ant on 2017-01-19 12:13:31 EST ---

REVIEW: http://review.gluster.org/16428 (packaging: python2 cleanup) posted (#3) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 1 Worker Ant 2017-01-20 16:00:24 UTC
REVIEW: http://review.gluster.org/16446 (packaging: python/python2(/python3) cleanup) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2017-01-31 09:13:44 UTC
REVIEW: https://review.gluster.org/16487 (packaging: python/python2(/python3) cleanup, again) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2017-01-31 13:22:13 UTC
COMMIT: https://review.gluster.org/16487 committed in release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com) 
------
commit f90f5b26e32d5bc7bd6877d7323cd1965b5597cb
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Jan 31 04:10:13 2017 -0500

    packaging: python/python2(/python3) cleanup, again
    
    missed a couple things in the previous patch
    
    mainline change http://review.gluster.org/#/c/16486/
    mainline BZ 1414902
    
    Change-Id: I0ebd5c431abd9af5e1b680ad52318219edb4bfa7
    BUG: 1415226
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/16487
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>

Comment 4 Worker Ant 2017-02-07 14:33:36 UTC
REVIEW: https://review.gluster.org/16557 (packaging: python/python2(/python3) cleanup, again) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 5 Worker Ant 2017-02-07 19:04:29 UTC
COMMIT: https://review.gluster.org/16557 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit bcef8e60a186bc69673aa86e8065f9252b71563c
Author: Kaleb S. KEITHLEY <kkeithle@redhat.com>
Date:   Tue Feb 7 09:29:15 2017 -0500

    packaging: python/python2(/python3) cleanup, again
    
    mistake missed in the previous patches
    
    see https://review.gluster.org/16487 and
    https://review.gluster.org/16446
    
    BUG: 1415226
    Change-Id: I3d1b04d1107a651a4ee0b816ccc04f8bff13917c
    Signed-off-by: Kaleb S. KEITHLEY <kkeithle@redhat.com>
    Reviewed-on: https://review.gluster.org/16557
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 6 Shyamsundar 2017-02-16 14:54:03 UTC
Reassigning this bug as there is still an outstanding python dependency issue.

(from rtalur) I saw this error while updating from 3.8 packages to 3.10 on centos7 and update fails. Please let us know if this is going to be a problem.

Transaction check error:
  file /usr/lib/python2.7/site-packages/gluster/__init__.pyc from
install of python2-gluster-3.11dev-0.58.gitc57808c.el7.centos.x86_64
conflicts with file from package python-gluster-3.8.8-1.el7.noarch
  file /usr/lib/python2.7/site-packages/gluster/__init__.pyo from
install of python2-gluster-3.11dev-0.58.gitc57808c.el7.centos.x86_64
conflicts with file from package python-gluster-3.8.8-1.el7.noarch

Some further mail discussions:
> From Kaleb:
> I suspect it's the python2-glusterfs (3.10) versus python-gluster (3.8). We
> probably need a Obsoletes: python-gluster in the 3.10 python2-gluster part
> of the .spec, or something like that.
>
> Perhaps Neils knows for certain?

From Niels:
Yes, it would need a "Obsoletes: python-gluster < $version" and we need
to make sure that it also provides python-gluster $version. The 2nd may
be done by the python scriptlets automagically. But in case it does not
do it, we need to add it to prevent breakage of other packages that
depend on this.

Comment 7 Worker Ant 2017-02-21 09:26:26 UTC
REVIEW: https://review.gluster.org/16696 (rpm: replace renamed python-gluster with python2-gluster) posted (#1) for review on release-3.10 by Niels de Vos (ndevos@redhat.com)

Comment 8 Worker Ant 2017-02-21 13:43:08 UTC
COMMIT: https://review.gluster.org/16696 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit a870c7c7255cd915e9b281517bc2bf1b91b5f807
Author: Niels de Vos <ndevos@redhat.com>
Date:   Tue Feb 21 10:26:11 2017 +0100

    rpm: replace renamed python-gluster with python2-gluster
    
    When upgrading from < 3.10, the old python-gluster package causes
    conflicts with the newly renamed python2-gluster package.
    
    This can be solved by adding the appropriate Provides and Obsoletes to
    the python2-gluster RPM. Details on renaming packages are listed on the
    Fedora Packaging Guidelines.
    
    Cherry picked from commit 431011098efc5702a2f49fad1975fb956cdc9e00:
    > Change-Id: Ib143bf69022c45abe2d5e8d31d3375a6b85f75da
    > URL: https://fedoraproject.org/wiki/Packaging:Guidelines#Renaming.2FReplacing_Existing_Packages
    > BUG: 1414902
    > Signed-off-by: Niels de Vos <ndevos@redhat.com>
    > Reviewed-on: https://review.gluster.org/16649
    > Smoke: Gluster Build System <jenkins@build.gluster.org>
    > NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    > CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    > Reviewed-by: Prashanth Pai <ppai@redhat.com>
    > Reviewed-by: Anoop C S <anoopcs@redhat.com>
    
    Change-Id: Ib143bf69022c45abe2d5e8d31d3375a6b85f75da
    BUG: 1415226
    Signed-off-by: Niels de Vos <ndevos@redhat.com>
    Reviewed-on: https://review.gluster.org/16696
    Reviewed-by: Prashanth Pai <ppai@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>

Comment 9 Shyamsundar 2017-02-27 15:30:22 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-devel/2017-February/052173.html
[2] https://www.gluster.org/pipermail/gluster-users/

Comment 10 Shyamsundar 2017-03-06 17:44:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.