Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415279 - libgfapi: remove/revert glfs_ipc() changes targeted for 4.0
Summary: libgfapi: remove/revert glfs_ipc() changes targeted for 4.0
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: 3.10
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kaleb KEITHLEY
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: glusterfs-3.10.0
TreeView+ depends on / blocked
 
Reported: 2017-01-20 18:15 UTC by Kaleb KEITHLEY
Modified: 2017-03-06 17:44 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-15 13:54:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2017-01-20 18:15:39 UTC
Description of problem:

revert glfs_ipc() to 3.7.0 signature and associated symbol versioning


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Worker Ant 2017-01-20 18:19:18 UTC
REVIEW: http://review.gluster.org/16448 (libgfapi: remove/revert glfs_ipc() changes targeted for 4.0) posted (#1) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 2 Worker Ant 2017-01-20 18:28:49 UTC
REVIEW: http://review.gluster.org/16448 (libgfapi: remove/revert glfs_ipc() changes targeted for 4.0) posted (#2) for review on master by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 3 Worker Ant 2017-01-20 20:28:17 UTC
REVIEW: http://review.gluster.org/16450 (libgfapi: remove/revert glfs_ipc() changes targeted for 4.0) posted (#1) for review on release-3.10 by Kaleb KEITHLEY (kkeithle@redhat.com)

Comment 4 Shyamsundar 2017-03-06 17:44:03 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.