Bug 1415467 - in the SearchBox "Vms:uptime" doesn't work (column vms_elapsed_time does not exist)
Summary: in the SearchBox "Vms:uptime" doesn't work (column vms_elapsed_time does not ...
Keywords:
Status: CLOSED DUPLICATE of bug 1416837
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ovirt-4.1.1
: ---
Assignee: Shahar Havivi
QA Contact: Shira Maximov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 09:52 UTC by Shira Maximov
Modified: 2017-01-27 12:29 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 12:29:35 UTC
oVirt Team: Virt
tjelinek: ovirt-4.1?
rule-engine: blocker?
rule-engine: planning_ack+
tjelinek: devel_ack?
tjelinek: testing_ack?


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71252 0 master MERGED core: order VMs by uptime doesn't work 2017-01-29 07:35:56 UTC

Description Shira Maximov 2017-01-22 09:52:59 UTC
Description of problem:
the Queries : "uptime < 1" or "uptime > 1" doesn't work.

Version-Release number of selected component (if applicable):
Red Hat Virtualization Manager Version: 4.1.0.1-0.1.el7


How reproducible:
100%

Steps to Reproduce:
1.Select Vms Tab in webadmin 
2.Type & select from autocomplete "Vms:uptime> or <"

Actual results:
The search hangs forever (because bad SQL query)

Expected results:


Additional info:
error :
Sun Jan 22 11:51:14 GMT+200 2017 org.ovirt.engine.ui.frontend.Frontend
WARNING: Failure while invoking runQuery [StatementCallback; bad SQL grammar [SELECT * FROM ((SELECT distinct vms.* FROM  vms   WHERE  vms.elapsed_time < '86400' )  ORDER BY vm_name ASC ) as T1 OFFSET (1 -1) LIMIT 100]; nested exception is org.postgresql.util.PSQLException: ERROR: column vms.elapsed_time does not exist
  Position: 58, StatementCallback; bad SQL grammar [SELECT * FROM ((SELECT distinct vms_* FROM  vms   WHERE  vms_elapsed_time < '86400' )  ORDER BY vm_name ASC ) as T1 OFFSET (1 -1) LIMIT 100]; nested exception is org_postgresql_util_PSQLException: ERROR: column vms_elapsed_time does not exist
  Position: 58]

Comment 1 Tomas Jelinek 2017-01-25 09:43:41 UTC
ugly SQL exception, should be fixed soon

Comment 2 Red Hat Bugzilla Rules Engine 2017-01-25 09:43:46 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Red Hat Bugzilla Rules Engine 2017-01-25 11:46:14 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 4 Tomas Jelinek 2017-01-27 12:29:35 UTC

*** This bug has been marked as a duplicate of bug 1416837 ***


Note You need to log in before you can comment on or make changes to this bug.