Bug 1416837 - Order VMs by Uptime doesn't work
Summary: Order VMs by Uptime doesn't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: Frontend.WebAdmin
Version: 4.1.0.2
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: 4.1.1
Assignee: Shahar Havivi
QA Contact: Lucie Leistnerova
URL:
Whiteboard:
: 1415467 1436373 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 15:04 UTC by Lucie Leistnerova
Modified: 2017-04-21 09:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:33:31 UTC
oVirt Team: Virt
rule-engine: ovirt-4.1+
rule-engine: blocker+
rule-engine: planning_ack+
tjelinek: devel_ack+
pstehlik: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 71252 0 master MERGED core: order VMs by uptime doesn't work 2017-01-29 07:35:56 UTC
oVirt gerrit 71330 0 ovirt-engine-4.1 MERGED core: order VMs by uptime doesn't work 2017-01-30 09:20:36 UTC

Description Lucie Leistnerova 2017-01-26 15:04:30 UTC
Description of problem:
Order VMs by Uptime doesn't change order and freezes the list of VMs.

Version-Release number of selected component (if applicable):
ovirt-engine-webadmin-portal-4.1.0.2-0.1.el7.noarch

How reproducible: always


Steps to Reproduce:
1. go to VMs tab
2. click on Uptime column header

Actual results: order icon changes but order doesn't change. VMs table is not shown by going to other tab and going back to VMs tab.


Expected results: order properly changes


Additional info:
error in log

2017-01-23 13:25:19,151+01 ERROR [org.ovirt.engine.core.bll.SearchQuery] (default task-8) [f21ae3e8-5b59-49db-8202-7a9a3577baaf] Query 'SearchQuery' failed: StatementCallback; bad SQL grammar [SELECT * FROM ((SELECT distinct vms.* FROM  vms  )  ORDER BY elapsed_time DESC NULLS LAST,vm_name ASC ) as T1 OFFSET (1 -1) LIMIT 100]; nested exception is org.postgresql.util.PSQLException: ERROR: column "elapsed_time" does not exist
  Position: 62

Comment 1 Tomas Jelinek 2017-01-27 12:29:35 UTC
*** Bug 1415467 has been marked as a duplicate of this bug. ***

Comment 2 Red Hat Bugzilla Rules Engine 2017-01-31 08:39:42 UTC
This bug report has Keywords: Regression or TestBlocker.
Since no regressions or test blockers are allowed between releases, it is also being identified as a blocker for this release. Please resolve ASAP.

Comment 3 Lucie Leistnerova 2017-02-13 13:41:21 UTC
Order by Uptime works fine.

verified in ovirt-engine-webadmin-portal-4.1.1-0.1.el7.noarch

Comment 4 Allon Mureinik 2017-03-28 07:19:50 UTC
*** Bug 1436373 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.