Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415498 (digikam_qtav) - Media support not enabled
Summary: Media support not enabled
Keywords:
Status: CLOSED CANTFIX
Alias: digikam_qtav
Product: Fedora
Classification: Fedora
Component: digikam
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1415586 1426955 1546456 1854143 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-22 17:11 UTC by nicofo
Modified: 2020-07-06 15:24 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-22 18:39:57 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 375399 0 NOR RESOLVED No preview of video files 2020-07-06 15:23:41 UTC

Description nicofo 2017-01-22 17:11:40 UTC
Description of problem:

Digikam 5.4 has been released for Fedora, but the Media support is not enabled for Fedora 24.
In Help > Component Information, "Media Player Support" is "No".
From this version, Digikam now uses QtAV framework for video support.
Video support is a compilation option.

(same problem for Fedora 25: see https://bugs.kde.org/show_bug.cgi?id=375399 )

Comment 1 Rex Dieter 2017-01-22 18:39:57 UTC
Cantfix unfortunately, upstream choice of using qtav (and nonfree dependencies) prevent s the feature being in Fedora

Comment 2 nicofo 2017-01-23 22:09:41 UTC
Hi,
could you give please more information about this ("qtav prevents the feature being in Fedora") ? I see that qtav is a free project.

Providing only a part of Digikam, without video capabilities, makes it not very interesting for a lot of people. What is the alternative to have a full version of Digikam on Fedora ?

Comment 3 Rex Dieter 2017-01-24 01:11:50 UTC
See this post:
https://plus.google.com/+GillesCaulier/posts/L2Q2ke8h6Ze

where I commented that their reliance on a patent-encumbered library (ffmpeg), makes this feature not shippable in many distros (including fedora)

Comment 4 nicofo 2017-01-25 19:41:31 UTC
OK, thanks for the info.
Would it be possible to provide digikam from rpmfusion repository (that already provides ffmpeg and qtav) ?

(Probably it is not the right place to ask this. But providing a limited version of digikam is of course not a nice solution. Something must well be done otherwise Fedora will loose a great software).

Comment 5 Rex Dieter 2017-01-25 19:52:10 UTC
possible maybe... practical... not sure if it's worth all the extra work just for this single feature.

Now, if digikam provided that feature as an easy-addon plugin that could be installed extra... easy peasy.  (but I'm pretty sure that is not how it is currently implemented).

I encourage you to direct your (hopefully constructive) feedback to digikam upstream... I have given them mine in the thread above already.

Comment 6 Rex Dieter 2017-01-27 21:16:55 UTC
*** Bug 1415586 has been marked as a duplicate of this bug. ***

Comment 7 Rex Dieter 2017-02-27 00:10:29 UTC
*** Bug 1426955 has been marked as a duplicate of this bug. ***

Comment 8 Rex Dieter 2018-02-19 03:21:24 UTC
*** Bug 1546456 has been marked as a duplicate of this bug. ***

Comment 9 Rex Dieter 2020-07-06 15:24:04 UTC
*** Bug 1854143 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.