Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415586 - digikam is not built wit QtAV (video) support
Summary: digikam is not built wit QtAV (video) support
Keywords:
Status: CLOSED DUPLICATE of bug 1415498
Alias: None
Product: Fedora
Classification: Fedora
Component: digikam
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 07:29 UTC by Nils
Modified: 2017-01-27 21:16 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 13:11:43 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
KDE Software Compilation 375399 0 NOR RESOLVED No preview of video files 2020-07-06 15:23:37 UTC

Description Nils 2017-01-23 07:29:46 UTC
Digikam 5.4 uses QtAV for video thumbnails and viewing. The fedora package is built without QtAV support


Version-Release number of selected component (if applicable): 5.4


See: https://kojipkgs.fedoraproject.org//packages/digikam/5.4.0/1.fc25/data/logs/x86_64/build.log

-- Could NOT find QtAV (missing:  QTAV_LIBRARIES QTAV_INCLUDE_DIRS) 
-- QtAV_FOUND       = FALSE
-- QtAV_INCLUDE_DIR = QTAV_CORE_INCLUDE_DIR-NOTFOUND QTAV_WIDGETS_INCLUDE_DIR-NOTFOUND
-- QtAV_LIBRARIES   = QTAV_CORE_LIBRARY-NOTFOUND;QTAV_WIDGETS_LIBRARY-NOTFOUND
...
--  libqtav found............................ NO  (optional)
--  digiKam will be compiled without Media Player support.
--  Please install the libqtav (version >= 1.11.0) development package.

Comment 1 Rex Dieter 2017-01-23 13:11:43 UTC
digikam upstream use of QtAV is effectively nonfree (with ffmpeg dependencies), so we cannot enable that feature in fedora.  sorry, cantfix :(

Comment 2 Nils 2017-01-24 06:42:14 UTC
Ok. Thank you for the reply.

You could write a note into the README file. This could spare someone from searching for missing deps or other settings.

Comment 3 Rex Dieter 2017-01-27 21:16:55 UTC

*** This bug has been marked as a duplicate of bug 1415498 ***


Note You need to log in before you can comment on or make changes to this bug.