Bug 1415548 - strict dependence on specific perl version blocks system updates
Summary: strict dependence on specific perl version blocks system updates
Alias: None
Product: Fedora
Classification: Fedora
Component: polymake
Version: 25
Hardware: Unspecified
OS: Unspecified
Target Milestone: ---
Assignee: Jerry James
QA Contact: Fedora Extras Quality Assurance
: 1416952 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2017-01-23 02:56 UTC by Przemek Klosowski
Modified: 2017-12-12 10:47 UTC (History)
5 users (show)

Fixed In Version: polymake-3.0r2-4.fc26
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Last Closed: 2017-12-12 10:47:53 UTC
Type: Bug

Attachments (Terms of Use)

Description Przemek Klosowski 2017-01-23 02:56:53 UTC
Description of problem:
strict "perl = 4:5.24.0" require dependence blocks system update by preventing updating of perl and its dependencies (git, perl packages). The new version of perl is   4:5.24.1-381.fc25 

Version-Release number of selected component (if applicable):

How reproducible: every time

Steps to Reproduce:
1.dnf -y update --best

Actual results:
Error: package polymake-3.0r2-1.fc25.x86_64 requires perl = 4:5.24.0, but none of the providers can be installed.
package perl-4:5.24.0-377.fc25.x86_64 requires perl-libs = 4:5.24.0-377.fc25, but none of the providers can be installed

Expected results:
successful update

Comment 1 Przemek Klosowski 2017-01-23 02:59:19 UTC
Arguably, dnf error messages are deficient in this case, because  a simple 'dnf -y update' just says 'Skip  17 Packages...Nothing to do' without much explanation.

Comment 2 Przemek Klosowski 2017-01-25 03:56:49 UTC
Just wanted to mention that the usual trick of erasing the blocking package (polymake) doesn't  really work here, because too many packages depend on it (many pyton and python2 packages, as well as gap, sage, ocaml and several other: altogether 89 packages comprising 831MB). This is a pretty serious block---could the packagers please do something about it?

Comment 3 Edgar Hoch 2017-01-25 20:01:02 UTC
I think the problematic lines in polymake.spec are:

Requires:       perl(:MODULE_COMPAT_%{perl_version})
Requires:       perl = 4:%{perl_version}

Doesn't Fedora rpmbuild not find the required dependencies automatically, so these lines are unnecessary?


After reading the wiki pages I think these lines should be replaced by

Requires:  perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))

Comment 4 Edgar Hoch 2017-01-25 20:11:20 UTC
These wrong dependencies also break kickstart installation of Fedora 25 when the %packages section contains at least one of the lines

@engineering-and-scientific --optional

(because the group contains polymake as optional package)

together with at least one of

@editor --optional

which requires vim-common-2:7.4.1989-2.fc25.x86_64 which conflicts with vim-minimal-2:8.0.206-1.fc25.x86_64. vim-minimal is a mandatory package of group core.

See bug #1416518 .

Comment 5 Petr Pisar 2017-01-26 10:38:38 UTC
The strict dependency is on purpose. See bug #963486. Polymake maintainer know about the necessity to rebuild the package.

Comment 6 Petr Pisar 2017-01-30 08:46:24 UTC
*** Bug 1416952 has been marked as a duplicate of this bug. ***

Comment 7 Fedora End Of Life 2017-11-16 18:57:54 UTC
This message is a reminder that Fedora 25 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 25. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as EOL if it remains open with a Fedora  'version'
of '25'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version'
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not
able to fix it before Fedora 25 is end of life. If you would still like
to see this bug fixed and are able to reproduce it against a later version
of Fedora, you are encouraged  change the 'version' to a later Fedora
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's
lifetime, sometimes those efforts are overtaken by events. Often a
more recent Fedora release includes newer upstream software that fixes
bugs or makes them obsolete.

Comment 8 Fedora End Of Life 2017-12-12 10:47:53 UTC
Fedora 25 changed to end-of-life (EOL) status on 2017-12-12. Fedora 25 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.