Bug 1416952 - perl requires but gives "no providers" for perl-libs
Summary: perl requires but gives "no providers" for perl-libs
Keywords:
Status: CLOSED DUPLICATE of bug 1415548
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Jitka Plesnikova
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 22:20 UTC by George R. Goffe
Modified: 2017-01-30 08:46 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-30 08:46:24 UTC
Type: Bug


Attachments (Terms of Use)

Description George R. Goffe 2017-01-26 22:20:57 UTC
Description of problem:
attempting "dnf upgrade" gives several "no providers" messages

Version-Release number of selected component (if applicable):

rpm -q perl
perl-5.24.0-380.fc25.x86_64
rpm -q perl-libs
perl-libs-5.24.0-380.fc25.x86_64
How reproducible:
always

Steps to Reproduce:
1.dnf upgrade
2.
3.

Actual results:
see below

Expected results:
"normal" system upgrade

Additional info:

Error: nothing provides python2-rosdep >= 0.10.25 needed by python2-bloom-0.5.23-1.fc25.noarch.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazsim-timesource-1.0.0-2.fc25.x86_64.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazebo-1.0.0-2.fc25.x86_64.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazsim-timesource-1.0.0-2.fc25.x86_64.
package fawkes-plugin-laserht-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package polymake-3.0r2-1.fc25.x86_64 requires perl = 4:5.24.0, but none of the providers can be installed.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazebo-1.0.0-2.fc25.x86_64.
package fawkes-plugin-worldmodel-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package fawkes-plugin-worldmodel-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package fawkes-plugin-laserht-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package perl-4:5.24.0-380.fc25.x86_64 requires perl-libs(x86-64) = 4:5.24.0-380.fc25, but none of the providers can be installed.
package perl-4:5.24.0-380.fc25.x86_64 requires perl-libs(x86-64) = 4:5.24.0-380.fc25, but none of the providers can be installed

Comment 1 Paul Howarth 2017-01-27 09:16:47 UTC
This looks like it's related to:
https://bugzilla.redhat.com/show_bug.cgi?id=1415548

I think dnf's error messages are confusing here.

Comment 2 George R. Goffe 2017-01-27 22:47:42 UTC
Paul,

If there's a fix "on the way", I'll just wait for it. Do we know if that is the case?

Regards and thanks for your help and your time,

George...

Comment 3 Paul Howarth 2017-01-28 19:45:12 UTC
Looks like the polymake maintainer tried to fix it last weekend but the arm build failed (probably struggling for memory):

https://koji.fedoraproject.org/koji/taskinfo?taskID=17377906

Looks like you're stuck for the moment unless you're willing to uninstall polymake (and anything that depends on it) until the new version is built successfully.

The problems other than perl/polymake appear to be unrelated and will probably need fixing separately.

Comment 4 George R. Goffe 2017-01-29 01:04:00 UTC
Paul,

Thanks for your help with this situation... I'll just tough it out.

George...

Comment 5 Petr Pisar 2017-01-30 08:46:24 UTC

*** This bug has been marked as a duplicate of bug 1415548 ***


Note You need to log in before you can comment on or make changes to this bug.