Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1415562 - Should not show Node status in cockpit-ovirt-dashboard UI in regular hosts because nodectl is for RHVH only.
Summary: Should not show Node status in cockpit-ovirt-dashboard UI in regular hosts be...
Keywords:
Status: CLOSED DUPLICATE of bug 1380641
Alias: None
Product: cockpit-ovirt
Classification: oVirt
Component: Generic
Version: ---
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ovirt-4.1.1
: ---
Assignee: Ryan Barry
QA Contact: Ying Cui
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 05:02 UTC by Ying Cui
Modified: 2017-01-23 06:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-23 06:07:50 UTC
oVirt Team: Node
rule-engine: ovirt-4.1+
ycui: testing_ack+


Attachments (Terms of Use)
screenshot_cockpit-ovirt-dashboard (61.68 KB, image/png)
2017-01-23 05:02 UTC, Ying Cui
no flags Details


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 65589 0 None None None 2017-01-23 05:49:49 UTC

Description Ying Cui 2017-01-23 05:02:40 UTC
Created attachment 1243510 [details]
screenshot_cockpit-ovirt-dashboard

Description of problem:
Installed cockpit-ovirt-dashboard plugin in regular hosts, the cockpit-ovirt dashboard displays Node status with spinner icon always which is incorrect display, because nodectl is for RHVH only.

Version-Release number of selected component (if applicable):
cockpit-ovirt-dashboard-0.10.7-0.0.3.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. Installed the cockpit-ovirt-dashboard plugin in regular hosts, such as: RHEL 7.3 host.
2. Accessed cockpit UI by _root_ account.
3. Navigated to Virtualization Dashboard in Cockpit UI.
4. Checking Node Status UI.

Actual results:
1. Node status is always with spinner icon, and display "Can't check node status! Please run as an administrator!"

Expected results:
ovirt-node-ng-nodectl is for RHVH only, so here should not show Node status in cockpit-ovirt-dashbaord in regular hosts.

Comment 2 Ying Cui 2017-01-23 06:07:50 UTC

*** This bug has been marked as a duplicate of bug 1380641 ***


Note You need to log in before you can comment on or make changes to this bug.