Bug 1415739 - [starter][paid][prod]Current service degradation not reflected in web UI
Summary: [starter][paid][prod]Current service degradation not reflected in web UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 3.x
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Mike Dame
QA Contact: yasun
URL:
Whiteboard:
: 1415738 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-23 15:27 UTC by Will Gordon
Modified: 2018-05-07 17:24 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-07 17:24:33 UTC
Target Upstream Version:


Attachments (Terms of Use)
Screenshot of current service degradation (48.58 KB, image/png)
2017-01-23 15:28 UTC, Will Gordon
no flags Details
Screenshot of missing status icon in web ui where it would be expected (6.63 KB, image/png)
2017-01-23 15:29 UTC, Will Gordon
no flags Details

Description Will Gordon 2017-01-23 15:27:47 UTC
Description of problem:
The "Partially Degraded Service" posted to https://status.preview.openshift.com/ is not reflected anywhere in the OpenShift Online v3 web UI. (I know it was there for the PVC problem, so I would expect it to show for this as well).

Version-Release number of selected component (if applicable):
v3.4.0.39 (online version 3.4.0.13)

How reproducible:
Unsure as only 1 status incident has been posted that I've noticed it missing for

Steps to Reproduce:
1. Log in to https://console.preview.openshift.com
2. Look for service status next to ? icon in web console
3.

Actual results:
No status icon showing


Expected results:
A status icon reflecting the current service degradation


Additional info:
An additional goal may be to present an "all ok" icon at all other times, so that users would become used to checking there for the most current status, as opposed to requiring the user to check an additional page, just for confirmation that all is working as expected

Comment 1 Will Gordon 2017-01-23 15:28:48 UTC
Created attachment 1243633 [details]
Screenshot of current service degradation

Comment 2 Will Gordon 2017-01-23 15:29:23 UTC
Created attachment 1243634 [details]
Screenshot of missing status icon in web ui where it would be expected

Comment 3 Will Gordon 2017-01-23 17:14:12 UTC
*** Bug 1415738 has been marked as a duplicate of this bug. ***

Comment 4 Mike Dame 2017-01-23 20:07:14 UTC
It looks like the web console currently only considers incidents and the status page just shows "degraded performance" with no specific incidents reported. We can change this to also consider cluster performance as well, if that's something worth having.

Comment 5 Will Gordon 2017-01-23 20:10:43 UTC
I think at the very least, it can reduce confusion for a user who may be completely unaware that the Status page even exists, and just assumes it's something wrong with what they're doing, or something wrong with OpenShift as the product.

Hence my additional comment at the bottom regarding even providing a "all ok" icon when there are no problems, to increase user confidence.

Comment 6 Mike Dame 2017-02-10 17:56:20 UTC
PR for adding a "No-issues" icon to status bar: https://github.com/openshift/online/pull/810

If it's decided, we can also add a warning for general degraded performance to this PR.

Comment 7 Will Gordon 2017-02-10 17:59:09 UTC
My original intent was to provide clearer information to the customer, and I believe that adding a warning for general degraded performance falls in line with that.

So my preference would be for this to also include a warning for general degraded performance.

Nice PR btw! ;)

Comment 8 Mike Dame 2017-03-01 16:46:56 UTC
Added a reflection of general service degradation: for every component not current listed as operational, issue count will increase by 1 in UI

Comment 9 Will Gordon 2017-03-01 18:00:05 UTC
+1

Comment 10 Xiaoli Tian 2017-06-15 07:09:48 UTC
OpenShift Online Preview has been decommissioned, go to https://manage.openshift.com/ for using OpenShift Online starter cluster

Comment 11 Mike Dame 2017-06-15 13:20:00 UTC
This is still being considered for Online prod

Comment 13 Abhishek Gupta 2017-09-27 22:35:16 UTC
Mike: Has this been addressed and can QE test it?

Comment 16 Abhishek Gupta 2018-03-22 23:46:53 UTC
Lets get this ready/merged.

Comment 19 Mike Dame 2018-03-26 17:45:22 UTC
This looks like it was merged and deployed last week. Looking right now, there appear to be 3 clusters undergoing an upgrade which triggered a notification of "3 issues" in the console.

Comment 20 yasun 2018-03-27 05:57:03 UTC
Yes. 3 issued notification on free-stg.


Note You need to log in before you can comment on or make changes to this bug.