Bug 1415988 - traceback appears if org.selinux.relabel_on_boot(0) is called repeatedly
Summary: traceback appears if org.selinux.relabel_on_boot(0) is called repeatedly
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: policycoreutils
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Vit Mojzis
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 10:18 UTC by Milos Malik
Modified: 2019-02-27 12:34 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1754873 (view as bug list)
Environment:
Last Closed: 2019-02-27 12:34:01 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Milos Malik 2017-01-24 10:18:09 UTC
Description of problem:

Version-Release number of selected component (if applicable):
policycoreutils-2.5-8.el7.x86_64
policycoreutils-python-2.5-8.el7.x86_64
policycoreutils-devel-2.5-8.el7.x86_64
policycoreutils-gui-2.5-8.el7.x86_64

How reproducible:
* always

Steps to Reproduce:
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:1
method return sender=:1.53 -> dest=:1.52 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:1
method return sender=:1.53 -> dest=:1.54 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:0
method return sender=:1.53 -> dest=:1.55 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:0
Error org.freedesktop.DBus.Python.OSError: Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/slip/dbus/service.py", line 123, in reply_handler
    result = method(self, *p, **k)
  File "/usr/share/system-config-selinux/selinux_server.py", line 88, in relabel_on_boot
    os.unlink("/.autorelabel")
OSError: [Errno 2] No such file or directory: '/.autorelabel'
#

Actual results:
* repeated call of relabel_on_boot method with argument=1 does not cause a traceback
* repeated call of relabel_on_boot method with argument=0 causes a traceback

Expected results:
* repeated call of relabel_on_boot method with argument=1 does not cause a traceback
* repeated call of relabel_on_boot method with argument=0 does not cause a traceback

Comment 1 Zdenek Pytela 2019-02-27 12:34:01 UTC
This issue was not selected to be included in Red Hat Enterprise Linux 7.7 because it is seen either as low or moderate impact to a small number of use-cases. The next release will be in Maintenance Support 1 Phase, which means that qualified Critical and Important Security errata advisories (RHSAs) and Urgent Priority Bug Fix errata advisories (RHBAs) may be released as they become available.

We will now close this issue, but if you believe that it qualifies for the Maintenance Support 1 Phase, please re-open; otherwise, we recommend moving the request to Red Hat Enterprise Linux 8 if applicable.


Note You need to log in before you can comment on or make changes to this bug.