Bug 1754873 - traceback appears if org.selinux.relabel_on_boot(0) is called repeatedly
Summary: traceback appears if org.selinux.relabel_on_boot(0) is called repeatedly
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 8
Classification: Red Hat
Component: policycoreutils
Version: 8.1
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: 8.2
Assignee: Petr Lautrbach
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2019-09-24 09:34 UTC by Milos Malik
Modified: 2020-04-28 16:43 UTC (History)
6 users (show)

Fixed In Version: policycoreutils-2.9-7.el8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1415988
Environment:
Last Closed: 2020-04-28 16:42:41 UTC
Type: Bug
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2020:1779 0 None None None 2020-04-28 16:42:59 UTC

Description Milos Malik 2019-09-24 09:34:57 UTC
+++ This bug was initially created as a clone of Bug #1415988 +++

Description of problem:

Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.9-3.el8.noarch
policycoreutils-newrole-2.9-3.el8.x86_64
policycoreutils-gui-2.9-3.el8.noarch
policycoreutils-devel-2.9-3.el8.x86_64
policycoreutils-dbus-2.9-3.el8.noarch
python3-policycoreutils-2.9-3.el8.noarch
policycoreutils-2.9-3.el8.x86_64

How reproducible:
* always

Steps to Reproduce:
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:1
method return sender=:1.53 -> dest=:1.52 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:1
method return sender=:1.53 -> dest=:1.54 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:0
method return sender=:1.53 -> dest=:1.55 reply_serial=2
# dbus-send --system --print-reply --dest=org.selinux /org/selinux/object org.selinux.relabel_on_boot int64:0
Error org.freedesktop.DBus.Python.FileNotFoundError: FileNotFoundError: [Errno 2] No such file or directory: '/.autorelabel'
#

Actual results:
* repeated call of relabel_on_boot method with argument=1 does not cause a traceback
* repeated call of relabel_on_boot method with argument=0 causes a traceback

Expected results:
* repeated call of relabel_on_boot method with argument=1 does not cause a traceback
* repeated call of relabel_on_boot method with argument=0 does not cause a traceback

Comment 10 errata-xmlrpc 2020-04-28 16:42:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2020:1779


Note You need to log in before you can comment on or make changes to this bug.