Bug 1416088 - Rebase openvswitch to 2.6 in OSP 10
Summary: Rebase openvswitch to 2.6 in OSP 10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openvswitch
Version: unspecified
Hardware: x86_64
OS: Linux
high
medium
Target Milestone: z3
: 10.0 (Newton)
Assignee: Mike Burns
QA Contact: Ofer Blaut
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-24 14:53 UTC by Harshad More
Modified: 2017-06-28 15:27 UTC (History)
10 users (show)

Fixed In Version: openvswitch-2.6.1-10.git20161206.el7fdp dpdk-16.11-3.el7fdp driverctl-0.95-1.el7fdp
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-06-28 15:27:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:1587 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 Bug Fix and Enhancement Advisory 2017-06-28 19:11:42 UTC

Description Harshad More 2017-01-24 14:53:39 UTC
Description of problem:
openvswitch-2.5.0-22.git20160727.el7fdp.x86_64.rpm missing from openstack 10 repo

Version-Release number of selected component (if applicable):
OPS 10 channel

Actual results:
This package is being shipped through "Red Hat Virtualization ( v.4 for RHEL 7)" or "Red Hat Enterprise Linux Fast Datapath 7 x86_64" channel.


Expected results:

openvswitch-2.5.0-22.git20160727.el7fdp.x86_64.rpm should be visible in openstack 10 repo too

Additional info:

There was an article released as a bug fix for SSSE3 . https://access.redhat.com/solutions/2839041.

Bugzilla 1397048 has fixed the issue and an errata has been released https://rhn.redhat.com/errata/RHBA-2017-0027.html

But the updated package is not coming in OPS10 channel

Comment 3 Assaf Muller 2017-04-20 20:42:47 UTC
Do you know if OSP 10 Director has the correct patches to successfully update OVS 2.5.0-14 to 2.5.0-23 without restarting it?

Comment 4 Steven Mercurio 2017-04-20 22:49:00 UTC
The RPM is not only missing from the channel pullin to my Sat6 server but more importantly it is missing from the images included even in the latest OSP 10 image RPM!  This is a CRITICAL update as it fixes a total deploy failure on quite a number of HW platforms.  We could not get images deployed to work right at all but as soon as this RPM was updated everything worked fine.  SCross@emergent360.com did the bulk of this work and provide more info if needed but I know I had to pull the RPM from the RHEV channel and create a custom repo in a custom product that had this RPM then add the new repo to my OSP10 CV in order to work around this and Sam had to crack open the image to update this RPM so that the image would work right after deployment.

Comment 5 Marios Andreou 2017-04-21 07:00:59 UTC
(In reply to Assaf Muller from comment #3)
> Do you know if OSP 10 Director has the correct patches to successfully
> update OVS 2.5.0-14 to 2.5.0-23 without restarting it?

No it does not...

o/ - thanks for making me go looking for this - started typing a 'quick reply' best part of an hour ago. As you know it was a bit confusing as there were two parts, we removed the old workaround first (this DID happen for 10/newton) and then we added it again with the new flag. That second part did NOT happen for newton yet and so I  just posted https://review.openstack.org/458737 . 

*To be clear that means that currently OSP10 has NO workaround for ovs* until that lands. The relevant BZ for tracking that is https://bugzilla.redhat.com/show_bug.cgi?id=1431115 (OSP 11 clone at BZ 1431108 and upstream at https://bugs.launchpad.net/tripleo/+bug/1669714 )
.

Comment 6 Steven Mercurio 2017-04-21 07:16:48 UTC
I opened a RH case for this > 2 months ago.  Is there a reason the openvswitch-2.5.0-22.git20160727.el7fdp.x86_64.rpm can't be added to the OSP 10 channel coming down to my Sat6 server and added as well to the images as an RPM update?

This is a BIG issue for us as the HW we have has some CPU limitation this new RPM fixed.

All we had to do is just update this 1 RPM and everything worked great.  Granted by now that probabally isn't the latest RPM any longer but that was the latest in the RHEV channel at the time on my Sat6 server and it definitely fixed the issue.

Comment 7 Marios Andreou 2017-04-21 07:26:22 UTC
o/ Steven, for what its worth and to be clear, the reviews I point at in comment #5 are about upgrading opensvwitch in a RHEL OSP Director 9 environment to OSP 10 upgrade setting. I am not and can not comment on the release of a particular version of ovs through sat/repos as I have no involvement in that process whatsoever - I think some of the others on this BZ may be able to speak to that part in particular (though likely later today as they are US based)

thanks

Comment 11 errata-xmlrpc 2017-06-28 15:27:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1587


Note You need to log in before you can comment on or make changes to this bug.