Bug 1416160 - RFE: Backport support for multipart copy
Summary: RFE: Backport support for multipart copy
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 2.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 2.2
Assignee: Matt Benjamin (redhat)
QA Contact: shilpa
Bara Ancincova
URL:
Whiteboard:
: 1416514 (view as bug list)
Depends On:
Blocks: 1412948 1425877
TreeView+ depends on / blocked
 
Reported: 2017-01-24 17:55 UTC by Kyle Bader
Modified: 2017-07-30 16:00 UTC (History)
10 users (show)

Fixed In Version: RHEL: ceph-10.2.5-19.el7cp Ubuntu: ceph_10.2.5-12redhat1xenial
Doc Type: Enhancement
Doc Text:
.The Ceph Object Gateway now supports the S3 multipart copy operation The Ceph Object Gateway now supports the S3 API for multipart copy, including use of the `x-amz-copy-source` header. The multipart copy operation provides an optimized mechanism for copying existing objects larger than the 5G upload limit of the Amazon Simple Storage Service (S3). For details, see the https://access.redhat.com/documentation/en-us/red_hat_ceph_storage/2/html-single/developer_guide/#copy-multipart-upload[Copy Multipart Upload] section in the Developer Guide for Red Hat Ceph Storage 2.
Clone Of:
: 1425877 (view as bug list)
Environment:
Last Closed: 2017-03-14 15:48:26 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0514 normal SHIPPED_LIVE Red Hat Ceph Storage 2.2 bug fix and enhancement update 2017-03-21 07:24:26 UTC
Ceph Project Bug Tracker 12790 None None None 2017-01-24 19:13:55 UTC
Red Hat Bugzilla 1416514 None None None Never

Internal Links: 1416514

Description Kyle Bader 2017-01-24 17:55:29 UTC
Downstream support for multipart upload copy support, as described here:

http://javiermunhoz.com/blog/2016/10/12/multipart-upload-copy-part-goes-upstream-in-ceph.html

Relevant upstream work:

http://tracker.ceph.com/issues/12790

This is a feature that is important for analytics workloads.

Comment 2 Matt Benjamin (redhat) 2017-01-24 20:39:28 UTC
Added https://github.com/ceph/ceph/pull/13068

Comment 5 Matt Benjamin (redhat) 2017-01-25 22:28:53 UTC
*** Bug 1416514 has been marked as a duplicate of this bug. ***

Comment 22 shilpa 2017-02-22 16:39:37 UTC
Verified on ceph-10.2.5-27

Comment 24 errata-xmlrpc 2017-03-14 15:48:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0514.html


Note You need to log in before you can comment on or make changes to this bug.