Bug 1416164 - Ironic iDRAC driver WSMAN enumerate fails to return all entries
Summary: Ironic iDRAC driver WSMAN enumerate fails to return all entries
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-dracclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: 11.0 (Ocata)
Assignee: Chris Dearborn
QA Contact: nlevinki
URL:
Whiteboard:
Depends On:
Blocks: 1420884
TreeView+ depends on / blocked
 
Reported: 2017-01-24 18:02 UTC by Chris Dearborn
Modified: 2017-05-17 19:42 UTC (History)
18 users (show)

Fixed In Version: python-dracclient-1.1.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1420884 (view as bug list)
Environment:
Last Closed: 2017-05-17 19:42:43 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:1245 normal SHIPPED_LIVE Red Hat OpenStack Platform 11.0 Bug Fix and Enhancement Advisory 2017-05-17 23:01:50 UTC
OpenStack gerrit 424754 None None None 2017-01-25 10:55:14 UTC
Launchpad 1659052 None None None 2017-01-24 18:06:35 UTC

Description Chris Dearborn 2017-01-24 18:02:56 UTC
Description of problem:
When querying an enumeration using the WSMAN enumerate method, not all
entries are returned if there are more than max_elems (default of 100)
in the enumeration.

When querying an enumeration, the first response returns <wsman:Items>
in the body. Successive pulls, however, contain <wsen:Items>.

The current code always queries for <wsen:Items>, which causes the first
batch of attributes to be dropped only when the number of entries in
the enumeration exceeds max_elems.

Version-Release number of selected component (if applicable):
Ocata python-dracclient

How reproducible:
Enumerate the DCIM_iDRACCardEnumeration table using the wsman.enumerate method.

Steps to Reproduce:
1. Query DCIM_iDRACCardEnumeration using wsman.enumerate with logging turned up to DEBUG.
2. Note that entries that are present in the first response are not present in the end results.

Actual results:
The first 100 entries in DCIM_iDRACCardEnumeration are discarded.

Expected results:
All entries in DCIM_iDRACCardEnumeration should be returned.

Additional info:
The patch for this is pending upstream:
https://review.openstack.org/#/c/424754/

Upstream bug:
https://bugs.launchpad.net/python-dracclient/+bug/1659052

Comment 1 Angus Thomas 2017-03-30 14:02:51 UTC
Patch was merged upstream

Comment 4 Dmitry Tantsur 2017-04-26 09:13:30 UTC
Chris, can Dell please do QA for this? It's going to be easier for you to reproduce the issue, I guess.

Comment 5 Chris Dearborn 2017-05-16 13:47:50 UTC
Confirmed that the fix is in place and working.

Comment 8 errata-xmlrpc 2017-05-17 19:42:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:1245


Note You need to log in before you can comment on or make changes to this bug.