Bug 1420884 - Ironic iDRAC driver WSMAN enumerate fails to return all entries - OSP 10
Summary: Ironic iDRAC driver WSMAN enumerate fails to return all entries - OSP 10
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-dracclient
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: z3
: 10.0 (Newton)
Assignee: Dmitry Tantsur
QA Contact: mlammon
URL:
Whiteboard:
Depends On: 1416164
Blocks: 1335596 1356451
TreeView+ depends on / blocked
 
Reported: 2017-02-09 18:24 UTC by Sean Merrow
Modified: 2017-06-28 15:27 UTC (History)
18 users (show)

Fixed In Version: python-dracclient-1.1.1-1.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1416164
Environment:
Last Closed: 2017-06-28 15:27:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1659052 0 None None None 2017-02-09 18:24:21 UTC
OpenStack gerrit 424754 0 None None None 2017-02-09 18:24:21 UTC
Red Hat Product Errata RHBA-2017:1587 0 normal SHIPPED_LIVE Red Hat OpenStack Platform 10 Bug Fix and Enhancement Advisory 2017-06-28 19:11:42 UTC

Description Sean Merrow 2017-02-09 18:24:21 UTC
+++ This bug was initially created as a clone of Bug #1416164 +++

Description of problem:
When querying an enumeration using the WSMAN enumerate method, not all
entries are returned if there are more than max_elems (default of 100)
in the enumeration.

When querying an enumeration, the first response returns <wsman:Items>
in the body. Successive pulls, however, contain <wsen:Items>.

The current code always queries for <wsen:Items>, which causes the first
batch of attributes to be dropped only when the number of entries in
the enumeration exceeds max_elems.

Version-Release number of selected component (if applicable):
Ocata python-dracclient

How reproducible:
Enumerate the DCIM_iDRACCardEnumeration table using the wsman.enumerate method.

Steps to Reproduce:
1. Query DCIM_iDRACCardEnumeration using wsman.enumerate with logging turned up to DEBUG.
2. Note that entries that are present in the first response are not present in the end results.

Actual results:
The first 100 entries in DCIM_iDRACCardEnumeration are discarded.

Expected results:
All entries in DCIM_iDRACCardEnumeration should be returned.

Additional info:
The patch for this is pending upstream:
https://review.openstack.org/#/c/424754/

Upstream bug:
https://bugs.launchpad.net/python-dracclient/+bug/1659052

Comment 1 Red Hat Bugzilla Rules Engine 2017-02-09 18:24:40 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 2 Sean Merrow 2017-02-09 18:26:56 UTC
This is a clone to get a backport to OSP 10

Comment 3 Red Hat Bugzilla Rules Engine 2017-02-09 18:27:12 UTC
This bugzilla has been removed from the release and needs to be reviewed and Triaged for another Target Release.

Comment 4 Dmitry Tantsur 2017-02-10 11:24:41 UTC
We may want to just rebase dracclient to the pending release.

Comment 7 errata-xmlrpc 2017-06-28 15:27:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:1587


Note You need to log in before you can comment on or make changes to this bug.