Bug 1416213 - EFK and Metrics Upgrade Documentation Points to the Wrong Deployer Templates
Summary: EFK and Metrics Upgrade Documentation Points to the Wrong Deployer Templates
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Alex Dellapenta
QA Contact: Vikram Goyal
Vikram Goyal
URL:
Whiteboard:
: 1418700 (view as bug list)
Depends On:
Blocks: 1474187
TreeView+ depends on / blocked
 
Reported: 2017-01-24 21:40 UTC by Nick Schuetz
Modified: 2020-06-11 13:14 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1474187 (view as bug list)
Environment:
Last Closed: 2017-04-26 21:01:24 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2899571 0 None None None 2017-02-02 09:43:50 UTC

Description Nick Schuetz 2017-01-24 21:40:27 UTC
Document URL: 

https://docs.openshift.com/container-platform/3.4/install_config/upgrading/manual_upgrades.html#manual-upgrading-efk-logging-stack

https://docs.openshift.com/container-platform/3.4/install_config/upgrading/manual_upgrades.html#manual-upgrading-cluster-metrics

Section Number and Name: 

Upgrading the EFK Logging Stack
and
Upgrading Cluster Metrics


Describe the issue: 

The instructions to apply the logging and metrics deployer templates point to the wrong location on the filesystem. 


Suggestions for improvement: 

They should have them point to:

/usr/share/ansible/openshift-ansible/roles/openshift_hosted_templates/files/v1.4/enterprise/logging-deployer.yaml

and

/usr/share/ansible/openshift-ansible/roles/openshift_hosted_templates/files/v1.4/enterprise/metrics-deployer.yaml

Additional information: 

The following documentation should also be updated to include the metrics and logging deployer templates too: https://docs.openshift.com/container-platform/3.4/install_config/upgrading/manual_upgrades.html#manual-upgrading-cluster-metrics

Comment 1 Alex Dellapenta 2017-02-03 23:19:42 UTC
These file paths were changed back in https://github.com/openshift/openshift-ansible/pull/2573.

Nick, PTAL @ the following PR?

https://github.com/openshift/openshift-docs/pull/3663

Comment 2 openshift-github-bot 2017-02-06 18:38:07 UTC
Commit pushed to master at https://github.com/openshift/openshift-docs

https://github.com/openshift/openshift-docs/commit/37aa52cbe245326040b259898363aced8d9b97bd
Merge pull request #3663 from adellape/updatetemplatepath

Bug 1416213: Update logging and metrics deployer paths

Comment 3 Alex Dellapenta 2017-02-06 18:39:08 UTC
Ack'd with Nick offline, Andrew tech reviewed in PR.

Comment 4 brice 2017-02-14 05:21:56 UTC
*** Bug 1418700 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.