Bug 1418700 - [DOCS] Path aggregate template logging is not valid
Summary: [DOCS] Path aggregate template logging is not valid
Keywords:
Status: CLOSED DUPLICATE of bug 1416213
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: brice
QA Contact: Xia Zhao
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-02 14:43 UTC by Akram Ben Aissi
Modified: 2020-06-29 07:50 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-14 05:21:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Akram Ben Aissi 2017-02-02 14:43:55 UTC
Document URL: 
https://docs.openshift.com/container-platform/3.4/install_config/aggregate_logging.html


Section Number and Name: 
https://docs.openshift.com/container-platform/3.4/install_config/aggregate_logging.html#pre-deployment-configuration
Describe the issue: 
The specified template path does not exist
    /usr/share/openshift/examples/infrastructure-templates/enterprise/logging-deployer.yaml

Suggestions for improvement: 
It should be replaced by:
    /usr/share/openshift/hosted/logging-deployer.yaml

Additional information: 
The template exists in other location alsp
    /usr/share/ansible-openshift/roles/openshift_hosted_examples/files/v1.4/enteprise/logging/logging-deployer.yaml

Comment 1 Peng Li 2017-02-03 08:07:38 UTC
Add Bug 1415268 , Installer but not Logging should solve this issue, the solution for these 2 bugs should be alike.

Comment 2 brice 2017-02-06 04:17:48 UTC
Akramn

Both of these files are on my instance...

Can I ask what version of OCP you're install is? Mine is 3.4, but I upgraded from 3.3. I've checked another instance (a freshly installed 3.4) and only your suggested file above exists, not the one the docs say. I'm thinking this is just something that was left behind in the upgrade to 3.4 docs.

Let me know, and I can fix up the docs.
Thanks

Comment 3 brice 2017-02-14 05:21:56 UTC
I can verify that it was a 3.3 -> 3.4 change, and since this BZ has been reported, it was fixed in the docs with the following PR:

https://github.com/openshift/openshift-docs/pull/3663

I'll mark this BZ as a duplicate.

If there's any issues, let me know.

*** This bug has been marked as a duplicate of bug 1416213 ***


Note You need to log in before you can comment on or make changes to this bug.