Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1416332 - [z-stream clone - 4.0.7] Host is marked as non responsive after upgrade
Summary: [z-stream clone - 4.0.7] Host is marked as non responsive after upgrade
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.0.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: ovirt-4.0.7
: ---
Assignee: Moti Asayag
QA Contact: Lukas Svaty
URL:
Whiteboard:
: 1417873 (view as bug list)
Depends On: 1383229
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-25 10:09 UTC by rhev-integ
Modified: 2020-02-14 18:33 UTC (History)
23 users (show)

Fixed In Version: upgrade
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1383229
Environment:
Last Closed: 2017-03-13 13:28:17 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:0542 0 normal SHIPPED_LIVE Red Hat Virtualization Manager 4.0.7 2017-03-16 19:25:04 UTC

Comment 4 rhev-integ 2017-01-25 10:10:01 UTC
Moving back to MODIFIED, so it can be added to 4.0.7 errata

(Originally by Martin Perina)

Comment 5 Petr Kubica 2017-01-31 11:13:04 UTC
*** Bug 1417873 has been marked as a duplicate of this bug. ***

Comment 7 Lukas Svaty 2017-03-03 13:38:18 UTC
2 scenarios tests:
RHEL based hosts - passed
RHVH - failed

host stuck in Not Responsible after successful upgrade
RHVH version: rhvh-4.0-0.20170302.0+1

moving back to ASSIGNED (FailedQA)

Comment 8 Moti Asayag 2017-03-05 08:11:47 UTC
(In reply to Lukas Svaty from comment #7)
> 2 scenarios tests:
> RHEL based hosts - passed
> RHVH - failed

Was it a real host with a resolved hostname to the same IP or a VM set with DHCP ?

> 
> host stuck in Not Responsible after successful upgrade
> RHVH version: rhvh-4.0-0.20170302.0+1

Could you attach logs for this case ?

> 
> moving back to ASSIGNED (FailedQA)

Comment 9 Lukas Svaty 2017-03-05 10:09:01 UTC
moving needinfo to pbrilla who tested the rhevh part

Comment 10 Lukas Svaty 2017-03-08 10:25:42 UTC
(In reply to Moti Asayag from comment #8)
> (In reply to Lukas Svaty from comment #7)
> > 2 scenarios tests:
> > RHEL based hosts - passed
> > RHVH - failed
> 
> Was it a real host with a resolved hostname to the same IP or a VM set with
> DHCP ?
> 
Yes, baremetal host with resolvable hostname and ip

> > 
> > host stuck in Not Responsible after successful upgrade
> > RHVH version: rhvh-4.0-0.20170302.0+1
> 
> Could you attach logs for this case ?
> 
> > 
> > moving back to ASSIGNED (FailedQA)

Comment 15 Pavol Brilla 2017-03-13 13:33:59 UTC
I did twice test on Thursday with Moti on evironment provided by lsvaty, both of them passed.

Today I tested scenario according to steps in #c12

Engine 4.0.7, was updated to this latest build last week:
# rpm -q rhevm ovirt-host-deploy
rhevm-4.0.7.4-0.1.el7ev.noarch
ovirt-host-deploy-1.5.5-1.el7ev.noarch

Host  rhvh 4.0.6 async - latest live 20170201 was upgraded to latest dev build currently available:
# imgbase w
[INFO] You are on rhvh-4.0-0.20170307.0+1


For me host went green in 5 minutes.

Comment 16 Pavol Brilla 2017-03-14 10:17:20 UTC
Just adding relating events to this bug, as I was approach by colleagues to make it more clearer:

Mar 13, 2017 1:05:18 PM Status of host slot6c was set to Up.
Mar 13, 2017 12:59:49 PM Host slot6c upgrade was completed successfully.
Mar 13, 2017 12:59:49 PM Host slot6c was restarted using SSH by the engine.
Mar 13, 2017 12:59:32 PM Installing Host slot6c. Stage: Termination.


Note You need to log in before you can comment on or make changes to this bug.