Bug 1416580 - Corrupted guest icons on host display, but not corrupted in guest screen capture
Summary: Corrupted guest icons on host display, but not corrupted in guest screen capture
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Virtualization Tools
Classification: Community
Component: virt-viewer
Version: unspecified
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Berrangé
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1508847
TreeView+ depends on / blocked
 
Reported: 2017-01-25 22:01 UTC by Phil Turmel
Modified: 2020-09-11 11:06 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1508847 (view as bug list)
Environment:
Last Closed: 2020-09-11 11:06:25 UTC


Attachments (Terms of Use)
Windows 7 VM showing Toolbar Icon corruption visible in the host (145.42 KB, image/png)
2017-01-25 22:01 UTC, Phil Turmel
no flags Details
Windows 7 VM showing Toolbar Icons not corrupted from the guest display buffer (143.36 KB, image/png)
2017-01-25 22:02 UTC, Phil Turmel
no flags Details
virt-viewer 7.0 taskbar disruption (20.44 KB, image/jpeg)
2017-10-27 09:40 UTC, Eric Baplue
no flags Details
Disruption with Themes service started (123.02 KB, image/jpeg)
2017-10-27 10:02 UTC, Eric Baplue
no flags Details
Disruption with Themes service stoped (120.46 KB, image/jpeg)
2017-10-27 10:03 UTC, Eric Baplue
no flags Details

Description Phil Turmel 2017-01-25 22:01:29 UTC
Created attachment 1244474 [details]
Windows 7 VM showing Toolbar Icon corruption visible in the host

Description of problem:

Most applications in my Windows 7 guests that have toolbars will show random corruption of the visuals of the toolbar icons and scattered text elements.  Screen capture within the guest, transferred to the Gimp via spice clipboard show no corruption.  Screen capture of the virt-viewer window at the same time shows the corruptions.  The corruptions are typically slanted grey lines.

Environment is KDE 5.8.5 in gentoo w/ vanilla kernel 4.8.15

Version-Release number of selected component (if applicable):

libvirt-2.5.0:0/2.5.0
libvirt-glib-1.0.0:0
qemu-2.8.0:0
spice-0.13.3:0
spice-gtk-0.33-r1:0
spice-protocol-0.12.12:0
virt-manager-1.4.0-r2:0
virt-viewer-5.0:0

How reproducible:

Windows 7 VM, fully updated, with QXL driver from spice-quest-tools-0.100, PDFCreator or similar older application.  It seems that it is triggered by icons that are initially greyed out, then never update correctly thereafter.  The application in which I encounter this most often is an industrial software package called RSLogix5000, featured in the screen captures.

Corruption often affects grey-out text in dialog boxes, too.

The corruption, if it doesn't appear immediately, almost certainly appears if the virt-viewer window is then resized.

Steps to Reproduce:
1.  Open virt-viewer with Win7 guest
2.  Open affected application
3.  Resize virt-viewer window

Actual results:

See screen capture taken in the host.  Note slanted grey lines w/ artifacts over many toolbar icons.

Expected results:

See corresponding screen capture taken in the guest.  Transferred to the host via shared clipboard.  No corruption visible on any icons.

Additional info:

Comment 1 Phil Turmel 2017-01-25 22:02:55 UTC
Created attachment 1244477 [details]
Windows 7 VM showing Toolbar Icons not corrupted from the guest display buffer

Comment 2 Eric Baplue 2017-10-27 09:40:25 UTC
Created attachment 1344234 [details]
virt-viewer 7.0 taskbar disruption

Comment 3 Eric Baplue 2017-10-27 09:49:33 UTC
I have the same disruption but was able to track the cause down to the Windows Themes.

How reproducible:
The problem occures with virt-viewer 6.0 64bit on a Windows 7 client and with virt-viewer 7.0 on xubuntu 14.04 (Igel Thin Client with firmware 5.12.100).
The problem does not exist with the 3.0-176 version that RedHat delivers with RHEV 3.6/4.1

To reproduse just stop the Themes service and I have the problem.
When the service is running it depends on the Theme you chose how much disruption you have (no disruption seems not be possible)

Comment 4 Eric Baplue 2017-10-27 10:02:46 UTC
Created attachment 1344252 [details]
Disruption with Themes service started

Comment 5 Eric Baplue 2017-10-27 10:03:10 UTC
Created attachment 1344253 [details]
Disruption with Themes service stoped

Comment 6 Eric Baplue 2017-10-30 07:59:18 UTC
When I replace the display adapter to the Windows 7 standard vga adapter it seems that there is no disruption.

Comment 11 Phil Turmel 2017-12-21 18:19:46 UTC
The patch linked in dependent bug
https://bugzilla.redhat.com/show_bug.cgi?id=1508847#c29
fixes the corruption in my gentoo system, applied as a local portage patch.

Comment 12 Daniel Berrangé 2020-09-11 11:06:25 UTC
Closing since the patch linked in comment #11 is merged in upstream spice-gtk


Note You need to log in before you can comment on or make changes to this bug.