Bug 1416655 - --activate and --onboot kickstart network options not honored for bridge configured in kickstart via %pre section
Summary: --activate and --onboot kickstart network options not honored for bridge conf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 08:46 UTC by Radek Vykydal
Modified: 2017-08-01 08:53 UTC (History)
3 users (show)

Fixed In Version: anaconda-21.48.22.95-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 08:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1373360 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Bugzilla 1416687 0 unspecified CLOSED --activate and --onboot kickstart network options not honored for bridge configured in kickstart 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:2293 0 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Internal Links: 1373360 1416687

Description Radek Vykydal 2017-01-26 08:46:46 UTC
Description of problem:

--activate and --onboot options are not honored when configuring bridge devices in included kickstart snippet created in %pre section:

(only ens3 device is activated in dracut via boot option ip=ens3:dhcp)

%include /tmp/ksinclude
%pre
echo "network --device=bridge0  --bridgeslaves=ens3 --bootproto=dhcp --onboot=no" >> /tmp/ksinclude
echo "network --device=bridge1  --bridgeslaves=ens4 --bootproto=dhcp" >> /tmp/ksinclude
%end

We shoud also unify the names of ifcfg files for bridge slaves with non-%pre kickstart case,
ie instead of overwriting ifcfg-ens3, write additional ifcfg-bridge0_slave1


Version-Release number of selected component (if applicable):

RHEL 7.3
anaconda-21.48.22.93-1

How reproducible:


Steps to Reproduce:

Run installation (eg in kvm with 2 network devices) with ip=ens3:dhcp network boot option and the kickstart network configuration
%include /tmp/ksinclude
%pre
echo "network --device=bridge0  --bridgeslaves=ens3 --bootproto=dhcp --onboot=no" >> /tmp/ksinclude
echo "network --device=bridge1  --bridgeslaves=ens4 --bootproto=dhcp" >> /tmp/ksinclude
%end


Actual results:

bridge0 is not activated in installer
bridge1 is activated in installer
bridge0 has ONBOOT=no
slave of bridge0 (ifcfg-ens3) has ONBOOT=yes
bridge1 has ONBOOT=yes
slave of bridge1 (ifcfg-ens4) has ONBOOT=yes


Expected results:

The first network command has --activate set by default, so the expected results are:

bridge0 is activated in installer
bridge1 is not activated in installer
bridge0 has ONBOOT=no
slave of bridge0 (ifcfg-bridge0_slave1) has ONBOOT=no
bridge1 has ONBOOT=yes
slave of bridge1 (ifcfg-bridge1_slave1) has ONBOOT=yes

Additional info:

I'll add link to our kickstart test for this case.

Comment 1 Radek Vykydal 2017-01-26 09:50:56 UTC
https://github.com/rhinstaller/anaconda/pull/938

Comment 4 Peter Kotvan 2017-05-09 12:57:05 UTC
Verified on RHEL-7.4-20170504.0 with anaconda-21.48.22.111-1.el7. Thanks.

Comment 5 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.