Bug 1416687 - --activate and --onboot kickstart network options not honored for bridge configured in kickstart
Summary: --activate and --onboot kickstart network options not honored for bridge conf...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda
Version: 7.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Radek Vykydal
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 09:14 UTC by Radek Vykydal
Modified: 2017-08-01 08:53 UTC (History)
3 users (show)

Fixed In Version: anaconda-21.48.22.95-1
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-08-01 08:53:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1373360 1 None None None 2021-01-20 06:05:38 UTC
Red Hat Bugzilla 1416655 0 unspecified CLOSED --activate and --onboot kickstart network options not honored for bridge configured in kickstart via %pre section 2021-02-22 00:41:40 UTC
Red Hat Product Errata RHBA-2017:2293 0 normal SHIPPED_LIVE anaconda bug fix and enhancement update 2017-08-01 12:39:44 UTC

Internal Links: 1373360 1416655

Description Radek Vykydal 2017-01-26 09:14:23 UTC
Description of problem:

--activate and --onboot options are not honored when configuring bridge devices in kickstart

Version-Release number of selected component (if applicable):

RHEL 7.3
anaconda-21.48.22.93-1

How reproducible:

Always

Steps to Reproduce:

Run installation (eg in kvm with 2 network devices) with ip=ens3:dhcp network boot option and the kickstart network configuration:

network --device=bridge0  --bridgeslaves=ens3 --bootproto=dhcp --onboot=no
network --device=bridge1  --bridgeslaves=ens4 --bootproto=dhcp

Actual results:

bridge1 is activated in installer
slave of bridge0 has ONBOOT=yes set in ifcfg file (ifcfg-bridge0_slave1)

Expected results:

bridge1 is not activated in installer (because no --activate option is set)
slave of bridge0 has ONBOOT=no set in ifcfg file (ifcfg-bridge0_slave1)

Additional info:

Comment 4 Peter Kotvan 2017-05-09 12:43:04 UTC
Verified on RHEL-7.4-20170504.0 with anaconda-21.48.22.111-1.el7. Thanks.

Comment 5 errata-xmlrpc 2017-08-01 08:53:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2293


Note You need to log in before you can comment on or make changes to this bug.