Bug 1416786 - [IntService_public_324]Deploy logging with ansible, failed TASK [openshift_logging : start fluentd]
Summary: [IntService_public_324]Deploy logging with ansible, failed TASK [openshift_lo...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.z
Assignee: ewolinet
QA Contact: Peng Li
URL:
Whiteboard:
Depends On: 1418911
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 12:13 UTC by Peng Li
Modified: 2017-10-25 13:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-10-25 13:00:48 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3049 0 normal SHIPPED_LIVE OpenShift Container Platform 3.6, 3.5, and 3.4 bug fix and enhancement update 2017-10-25 15:57:15 UTC

Description Peng Li 2017-01-26 12:13:52 UTC
Description of problem:
Try to deploy logging using ansible, task failed at TASK [openshift_logging : start fluentd], it seems fail at step 'label node'

oc get $node1 $node2 -o jsonpath='{.metadata.labels}'

Attach the ansible log and standard output of above command
Note that I test it on 3.4.1, but it should have the same error in 3.5

Version-Release number of selected component (if applicable):
openshift v3.4.1.2


How reproducible:
always

Steps to Reproduce:
1. git clone https://github.com/openshift/openshift-ansible.git
2. install httpd-tools and jdk-8 on master
3. prepare inventory file

[oo_first_master]
$master ansible_user=root ansible_ssh_user=root ansible_ssh_private_key_file="/home/penli/.ssh/libra.pem" openshift_public_hostname=$master

[oo_first_master:vars]
deployment_type=openshift-enterprise
openshift_release=v3.4.1

openshift_logging_install_logging=true

openshift_logging_kibana_hostname=kibana.$subdomain
public_master_url=https://$master:8443

openshift_logging_image_prefix=registry.ops.openshift.com/openshift3/
openshift_logging_image_version=3.5.0

openshift_logging_namespace=logging

openshift_logging_es_memory_limit=1024Mi

4.ansible-playbook  -vvv  -i  ~/inventory  playbooks/common/openshift-cluster/openshift_metrics.yml

Actual results:
task fail and abort.

Expected results:
task finished and logging is deployed

Additional info:
ansible log and standard output of oc command attached.

Comment 6 Xia Zhao 2017-02-07 05:31:24 UTC
Fixed with the latest logging deployment playbooks on openshift-ansible, the logs:

TASK [openshift_logging : start fluentd] ***************************************
task path: /root/openshift-ansible/roles/openshift_logging/tasks/start_cluster.yaml:12
included: /root/openshift-ansible/roles/openshift_logging/tasks/label_node.yaml for $master
included: /root/openshift-ansible/roles/openshift_logging/tasks/label_node.yaml for $master

And fluentd was actually started:
# oc get po -n xiazhao
NAME                          READY     STATUS             RESTARTS   AGE
logging-curator-1-m8mfv       1/1       Running            0          1m
logging-es-3okue3pz-1-fbvf9   0/1       CrashLoopBackOff   3          1m
logging-fluentd-0k0pg         1/1       Running            0          2m
logging-fluentd-tgsck         1/1       Running            0          1m
logging-kibana-1-8h9w1        2/2       Running            0          1m

Comment 8 errata-xmlrpc 2017-10-25 13:00:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049


Note You need to log in before you can comment on or make changes to this bug.