Bug 1418911 - [IntService_public_324] TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] failed
Summary: [IntService_public_324] TASK [lib_openshift : lib_openshift ensure python-rua...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.5.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.5.z
Assignee: Jeff Cantrill
QA Contact: Xia Zhao
URL:
Whiteboard:
: 1418910 (view as bug list)
Depends On:
Blocks: 1414625 1415447 1415593 1416786
TreeView+ depends on / blocked
 
Reported: 2017-02-03 06:00 UTC by Xia Zhao
Modified: 2017-10-25 13:00 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-10-25 13:00:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
full ansible log (77.86 KB, text/plain)
2017-02-03 06:00 UTC, Xia Zhao
no flags Details
20170204 log for TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] failed (2.87 KB, text/plain)
2017-02-04 05:33 UTC, Xia Zhao
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3049 0 normal SHIPPED_LIVE OpenShift Container Platform 3.6, 3.5, and 3.4 bug fix and enhancement update 2017-10-25 15:57:15 UTC

Description Xia Zhao 2017-02-03 06:00:46 UTC
Created attachment 1247366 [details]
full ansible log

Description of problem:
Deploy logging with ansible, failed at TASK Ensuring ruamel.yaml package is on target:
TASK [openshift_logging : Ensuring ruamel.yaml package is on target] ***********
task path: /home/xiazhao/openshift-ansible/roles/openshift_logging/tasks/main.yaml:15
Using module file /usr/lib/python2.7/site-packages/ansible/modules/core/commands/command.py
<${master-dns}> ESTABLISH SSH CONNECTION FOR USER: root
<${master-dns}> SSH: EXEC ssh -C -o ControlMaster=auto -o ControlPersist=60s -o StrictHostKeyChecking=no -o 'IdentityFile="/home/xiazhao/cfile/libra.pem"' -o KbdInteractiveAuthentication=no -o PreferredAuthentications=gssapi-with-mic,gssapi-keyex,hostbased,publickey -o PasswordAuthentication=no -o User=root -o ConnectTimeout=10 -o ControlPath=/home/xiazhao/.ansible/cp/ansible-ssh-%h-%p-%r ${master-dns} '/bin/sh -c '"'"'/usr/bin/python && sleep 0'"'"''
fatal: [${master-dns}]: FAILED! => {
    "changed": true, 
    "cmd": [
        "yum", 
        "install", 
        "-y", 
        "ruamel.yaml"
    ], 
    "delta": "0:00:01.377789", 
    "end": "2017-02-03 00:14:40.245197", 
    "failed": true, 
    "invocation": {
        "module_args": {
            "_raw_params": "yum install -y ruamel.yaml", 
            "_uses_shell": false, 
            "chdir": null, 
            "creates": null, 
            "executable": null, 
            "removes": null, 
            "warn": true
        }, 
        "module_name": "command"
    }, 
    "rc": 1, 
    "start": "2017-02-03 00:14:38.867408", 
    "warnings": [
        "Consider using yum module rather than running yum"
    ]
}

STDOUT:

Loaded plugins: amazon-id, rhui-lb, search-disabled-repos
No package ruamel.yaml available.


STDERR:

Error: Nothing to do


PLAY RECAP *********************************************************************
${master-dns} : ok=16   changed=0    unreachable=0    failed=1  

Version-Release number of selected component (if applicable):
# openshift version
openshift v3.5.0.6+87f6173
kubernetes v1.5.2+43a9be4
etcd 3.1.0-rc.0

How reproducible:
Always

Steps to Reproduce:

1. prepare the inventory file

[oo_first_master]
$master-public-dns ansible_user=root ansible_ssh_user=root ansible_ssh_private_key_file="~/cfile/libra.pem" openshift_public_hostname=$master-public-dns

[oo_first_master:vars]
deployment_type=openshift-enterprise
openshift_release=v3.5.0
openshift_logging_install_logging=true

openshift_logging_kibana_hostname=kibana.$sub-domain
public_master_url=https://$master-public-dns:8443

openshift_logging_image_prefix=registry.ops.openshift.com/openshift3/
openshift_logging_image_version=3.5.0

openshift_logging_namespace=xiazhao

2. Running the playbook from a control machine (my laptop) which is not oo_master:
git clone https://github.com/openshift/openshift-ansible
ansible-playbook -vvv -i ~/inventory   playbooks/common/openshift-cluster/openshift_logging.yml

Actual results:
failed at TASK [openshift_logging : create JKS generation pod]

Expected results:
Should complete successfully

Additional info:
1. Full ansible log attached
2. Manually installed the yaml package for python on openshift master, ansible is still failed by same error, which seemed not able to identify if pkg was installed correctly:

Here is how I installed the pkg on openshift master:
$ sudo yum install libyaml-devel python-devel

$ rpm -qa | grep -i pyyaml
PyYAML-3.10-11.el7.x86_64

Comment 2 Jeff Cantrill 2017-02-03 14:46:41 UTC
*** Bug 1418910 has been marked as a duplicate of this bug. ***

Comment 5 Xia Zhao 2017-02-04 05:31:31 UTC
bug title changed

Comment 6 Xia Zhao 2017-02-04 05:33:48 UTC
Created attachment 1247639 [details]
20170204 log for TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] failed

Comment 7 Peng Li 2017-02-04 06:55:41 UTC
This also affect Metrics Install.

Comment 8 Xia Zhao 2017-02-06 08:12:05 UTC
This issue is blocking most of 3.5 logging&metrics testing

Comment 9 Xia Zhao 2017-02-07 05:19:20 UTC
The original issue was fixed using the latest playbook from openshift-ansible repo. Please feel free to transfer back to ON_QA for closure. Thanks.

Comment 10 Xia Zhao 2017-02-08 02:17:39 UTC
Set to verified according to comment #9

Comment 11 Patrice FERLET 2017-02-12 12:42:12 UTC
I've got the same with latest openshift-ansible (master) if I ask to install metrics.

Regards,

Comment 12 Saul Alanis 2017-02-12 19:06:23 UTC
We are attempting to deploy Origin containerized version 1.4.1 using the latest openshift byo playbook and running into this issue.

TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on target] ***
task path: /var/tmp/openshift-ansible/playbooks/common/openshift-cluster/roles/lib_openshift/tasks/main.yml:2
fatal: [master01-server.com]: FAILED! => {
    "changed": false, 
    "failed": true, 
    "invocation": {
        "module_args": {
            "name": "python-ruamel-yaml", 
            "state": "present"
        }, 
        "module_name": "package"
    }, 
    "msg": "Could not find a module for unknown."

Our cluster is 100% Red Hat Atomic hosts which doesn't have this rpm. Looking that file it is an Ansible task and would like to comment it out so that we can finish deploying.

Any thoughts?

- Sincerely,
Saul Alanis

Comment 13 Saul Alanis 2017-02-12 21:36:47 UTC
I commented out the package installation task in file: openshift-ansible/playbooks/common/openshift-cluster/roles/lib_openshift/tasks/main.yml

Un-installed using the -> openshift-ansible/playbooks/adhoc/uninstall.yml

Re-ran the installer but now it's another issue that we're hitting, so *testing* commenting out the python-ruamel-yaml package task does no good.

Here's the results:

https://raw.githubusercontent.com/canit00/openshift/master/advanced_install_1.4.1_origin_fail

Can someone please provide guidance on how to go about getting help?

- Sincerely,
Saul Alanis

Comment 15 Peng Li 2017-02-14 02:42:56 UTC
(In reply to Saul Alanis from comment #12)
> We are attempting to deploy Origin containerized version 1.4.1 using the
> latest openshift byo playbook and running into this issue.
> 
> TASK [lib_openshift : lib_openshift ensure python-ruamel-yaml package is on
> target] ***
> task path:
> /var/tmp/openshift-ansible/playbooks/common/openshift-cluster/roles/
> lib_openshift/tasks/main.yml:2
> fatal: [master01-server.com]: FAILED! => {
>     "changed": false, 
>     "failed": true, 
>     "invocation": {
>         "module_args": {
>             "name": "python-ruamel-yaml", 
>             "state": "present"
>         }, 
>         "module_name": "package"
>     }, 
>     "msg": "Could not find a module for unknown."
> 
> Our cluster is 100% Red Hat Atomic hosts which doesn't have this rpm.
> Looking that file it is an Ansible task and would like to comment it out so
> that we can finish deploying.
> 
> Any thoughts?
> 
> - Sincerely,
> Saul Alanis

You are hitting this bug, this issue now exist only on a containerlized OCP, but would not affect RPM installed OCP.
https://bugzilla.redhat.com/show_bug.cgi?id=1421011

Comment 17 errata-xmlrpc 2017-10-25 13:00:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3049


Note You need to log in before you can comment on or make changes to this bug.