Bug 1416881 - [8.0.z] nova creates an invalid ethernet/bridge interface definition in virsh xml
Summary: [8.0.z] nova creates an invalid ethernet/bridge interface definition in virsh...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 8.0 (Liberty)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 8.0 (Liberty)
Assignee: Artom Lifshitz
QA Contact: Prasanth Anbalagan
URL:
Whiteboard:
Depends On: 1408464 1412834
Blocks: 1364146
TreeView+ depends on / blocked
 
Reported: 2017-01-26 17:05 UTC by Stephen Gordon
Modified: 2019-09-09 16:57 UTC (History)
14 users (show)

Fixed In Version: openstack-nova-12.0.6-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1408464
Environment:
Last Closed: 2017-03-08 17:50:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1649527 None None None 2017-01-26 17:05:56 UTC
OpenStack gerrit 411936 None None None 2017-01-26 17:05:56 UTC
Red Hat Product Errata RHBA-2017:0465 normal SHIPPED_LIVE openstack-nova bug fix advisory 2017-03-08 22:44:58 UTC

Comment 2 Stephen Gordon 2017-02-14 23:54:13 UTC
*** Bug 1422278 has been marked as a duplicate of this bug. ***

Comment 4 Prasanth Anbalagan 2017-02-28 18:39:28 UTC
# yum list installed | grep openstack-nova
openstack-nova-api.noarch            1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-cert.noarch           1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-common.noarch         1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-compute.noarch        1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-conductor.noarch      1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-console.noarch        1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-novncproxy.noarch     1:12.0.6-9.el7ost       @rhelosp-8.0-puddle
openstack-nova-scheduler.noarch      1:12.0.6-9.el7ost       @rhelosp-8.0-puddle


# nova boot --image cirros --flavor 1 vm1
+--------------------------------------+-----------------------------------------------+
| Property                             | Value                                         |
+--------------------------------------+-----------------------------------------------+
| OS-DCF:diskConfig                    | MANUAL                                        |
| OS-EXT-AZ:availability_zone          |                                               |
| OS-EXT-SRV-ATTR:host                 | -                                             |
| OS-EXT-SRV-ATTR:hypervisor_hostname  | -                                             |
| OS-EXT-SRV-ATTR:instance_name        | instance-00000001                             |
| OS-EXT-STS:power_state               | 0                                             |
| OS-EXT-STS:task_state                | scheduling                                    |
| OS-EXT-STS:vm_state                  | building                                      |
| OS-SRV-USG:launched_at               | -                                             |
| OS-SRV-USG:terminated_at             | -                                             |
| accessIPv4                           |                                               |
| accessIPv6                           |                                               |
| adminPass                            | LSaoaSRd85XH                                  |
| config_drive                         |                                               |
| created                              | 2017-02-28T18:32:38Z                          |
| flavor                               | m1.tiny (1)                                   |
| hostId                               |                                               |
| id                                   | 48e0606c-8a54-4a6d-8776-dad9ded972b8          |
| image                                | cirros (3182e6a0-f864-4322-9a38-ae753b03618e) |
| key_name                             | -                                             |
| metadata                             | {}                                            |
| name                                 | vm1                                           |
| os-extended-volumes:volumes_attached | []                                            |
| progress                             | 0                                             |
| security_groups                      | default                                       |
| status                               | BUILD                                         |
| tenant_id                            | 4a4c4acf46b44582be77d372fde055b7              |
| updated                              | 2017-02-28T18:32:38Z                          |
| user_id                              | 447f1923e88e4bfb96d6aa049647f6cf              |
+--------------------------------------+-----------------------------------------------+

# nova list
+--------------------------------------+------+--------+------------+-------------+---------------------+
| ID                                   | Name | Status | Task State | Power State | Networks            |
+--------------------------------------+------+--------+------------+-------------+---------------------+
| 48e0606c-8a54-4a6d-8776-dad9ded972b8 | vm1  | ACTIVE | -          | Running     | public=172.24.4.227 |
+--------------------------------------+------+--------+------------+-------------+---------------------+

# virsh list --all
 Id    Name                           State
----------------------------------------------------
 2     instance-00000001              running

# virsh dumpxml 2  > 2.xml
# virt-xml-validate 2.xml
2.xml validates
# virsh dumpxml 2
.
..
....
    <interface type='bridge'>
      <mac address='fa:16:3e:73:a7:9e'/>
      <source bridge='qbrcb251580-25'/>
      <target dev='tapcb251580-25'/>
      <model type='virtio'/>
      <alias name='net0'/>
      <address type='pci' domain='0x0000' bus='0x00' slot='0x03' function='0x0'/>
    </interface>
.....
...
.

Comment 6 errata-xmlrpc 2017-03-08 17:50:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2017-0465.html


Note You need to log in before you can comment on or make changes to this bug.