Bug 141692 - printconf-backend crashes during execution
printconf-backend crashes during execution
Status: CLOSED DUPLICATE of bug 131563
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-config-printer (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2004-12-02 18:16 EST by Udo Seidel
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-12-03 04:50:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Udo Seidel 2004-12-02 18:16:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
printconf-backend crashes during execution, while accessing the file
The value of XX depends on the shell variable LANG. If this variable
is set to en, no crashes occur. 

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. LANG=de_DE.UTF-8
2. printconf-backend
3. LANG=en_US.UTF-8
4. printconf-backend

Actual Results:  
# LANG=de_DE.UTF-8
# printconf-backend
Traceback (most recent call last):
  File "/usr/sbin/printconf-backend", line 7, in ?
    import backend
  File "/usr/share/printconf/util/backend.py", line 50, in ?
    which = cups_import.which_spooler ()
  File "/usr/share/printconf/util/cups_import.py", line 195, in
    return which
# LANG=en_US.UTF-8
# printconf-backend

Expected Results:  execution of printconf-backend without errors

Additional info:

This bug is proven on ia32e, x86_64 and i686.
Comment 1 Tim Waugh 2004-12-03 04:50:09 EST

*** This bug has been marked as a duplicate of 131563 ***

Note You need to log in before you can comment on or make changes to this bug.