Bug 1416948 - dnf upgrade noproviders for python2-rosdep needed by python2-bloom
Summary: dnf upgrade noproviders for python2-rosdep needed by python2-bloom
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 25
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: rpm-software-management
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-26 22:09 UTC by George R. Goffe
Modified: 2017-02-14 00:53 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-13 14:17:38 UTC
Type: Bug


Attachments (Terms of Use)
flat gzip'd file containing needed info. (1.13 KB, application/x-gzip)
2017-01-31 06:45 UTC, George R. Goffe
no flags Details
flat gzip'd file containing needed info. (1.02 KB, application/x-gzip)
2017-01-31 13:08 UTC, George R. Goffe
no flags Details

Description George R. Goffe 2017-01-26 22:09:19 UTC
Description of problem:

Upgrading this system gives several "no providers" messages

Version-Release number of selected component (if applicable):

python-bloom-0.5.21-1.fc25.noarch
How reproducible:

always
Steps to Reproduce:
1.dnf upgrade
2.
3.

Actual results:
several messages about providers not available

Expected results:

"normal" system upgrade
Additional info:

Error: nothing provides python2-rosdep >= 0.10.25 needed by python2-bloom-0.5.23-1.fc25.noarch.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazsim-timesource-1.0.0-2.fc25.x86_64.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazebo-1.0.0-2.fc25.x86_64.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazsim-timesource-1.0.0-2.fc25.x86_64.
package fawkes-plugin-laserht-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package polymake-3.0r2-1.fc25.x86_64 requires perl = 4:5.24.0, but none of the providers can be installed.
nothing provides libgazsim_msgs.so.1.0.0()(64bit) needed by fawkes-plugin-gazebo-1.0.0-2.fc25.x86_64.
package fawkes-plugin-worldmodel-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package fawkes-plugin-worldmodel-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package fawkes-plugin-laserht-0.5.0-30.fc25.x86_64 requires libfawkescore.so.0.5.0()(64bit), but none of the providers can be installed.
package perl-4:5.24.0-380.fc25.x86_64 requires perl-libs(x86-64) = 4:5.24.0-380.fc25, but none of the providers can be installed.
package perl-4:5.24.0-380.fc25.x86_64 requires perl-libs(x86-64) = 4:5.24.0-380.fc25, but none of the providers can be installed

Comment 1 Igor Gnatenko 2017-01-29 12:02:30 UTC
$ dnf repolist
$ dnf config-manager --dump

Comment 2 George R. Goffe 2017-01-31 06:45:02 UTC
Created attachment 1246092 [details]
flat gzip'd file containing needed info.

Igor,

Here's the info you've requested.

Thanks for your help.

George...

Comment 3 George R. Goffe 2017-01-31 09:34:26 UTC
Igor,

I looked in /etc/yum.repos.d a few minutes ago and found two rpmnew files. Apparently I missed a repo update?

I renamed them and am now running dnf. It's struggling with downloads... several curl code 18. Sigh.

I'll post the upgrade results here when it's done.

I hope this wasn't a wild goose chase.

George...

Comment 4 George R. Goffe 2017-01-31 13:08:52 UTC
Created attachment 1246228 [details]
flat gzip'd file containing needed info.

The previous file was from the wrong system.

The 26 system had the rpmnew files.

Apologies for my confusion.

Comment 5 Igor Gnatenko 2017-02-06 13:02:56 UTC
Try `dnf distro-sync` and see what it says.

Comment 6 George R. Goffe 2017-02-06 19:05:02 UTC
Igor,

Thanks for your help with this bug. I have bigger problems now. Sigh...

I'll try your suggestion when I'm able to boot the system. I wrote "[Bug 1419432] kernel panic " general protection no entropy gathe libc-2.24.90.so" last night. I had experienced the panic before and always went to the previous kernel which worked. Subsequent application of updates removed the last kernel that worked while adding a new kernel... which also panic'd. I was hoping someone would fix the bug so I wouldn't have to write a bug. 

Getting panic data is rather difficult so finally I was FORCED to research doing that. Adding "console=ttyS0 console=ttyS0 ignore loglevel" to the end of the kernel line of the grub.cfg file and setting the VirtualBox "serial" port settings to point to a host file, solved that problem. 

I updated the system with rpms for kernel et. al., and glibc et. al. on a live system but that was awkward because the recovery kernel couldn't "see" my network card. Argh! I should write a bug about that! It was seemingly unending repetition of steps... boot live, download the rpms, reboot the emergency kernel, apply the rpms downloaded, reboot again selecting the non-emergency kernel. Sigh... 

It seems that the "--force" option of rpm does not apply to downleveling packages. Who knew? Another bug?

If you have any ideas about the new bug, please let me know.

Comment 7 Igor Gnatenko 2017-02-13 14:17:38 UTC
Unfortunately, bugzilla is not best place to solve problems with broken system. You can try users@fedoraproject.org or #fedora on freenode to get help..


I believe that original bug is solvable with dnf distro-sync.

Comment 8 George R. Goffe 2017-02-14 00:53:19 UTC
Igor,

I got a clue from the responder for the bug report I wrote. It seems that some FIPS packages got installed by misteak... mine. Sigh... I removed them and reinstalled the kernel and the problem went away. Yay!

Thanks for your help and hard work,

George...


Note You need to log in before you can comment on or make changes to this bug.