Bug 1417084 - Please update bzr to fix incompatibility with Python ≥ 2.7.12
Summary: Please update bzr to fix incompatibility with Python ≥ 2.7.12
Keywords:
Status: CLOSED DUPLICATE of bug 1416571
Alias: None
Product: Fedora
Classification: Fedora
Component: bzr
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Henrik Nordström
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 08:05 UTC by Will Thompson
Modified: 2017-01-27 12:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 12:39:04 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1644003 0 None None None Never

Description Will Thompson 2017-01-27 08:05:16 UTC
Description of problem:

% bzr log --help
bzr: ERROR: exceptions.TypeError: first argument must be string or compiled pattern

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 649, in run_argv_aliases
    self.outf.write(self.get_help_text())
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 466, in get_help_text
    i18n.install()  # Install i18n only for get_help_text for now.
  File "/usr/lib64/python2.7/site-packages/bzrlib/i18n.py", line 92, in install
    _translations = install_translations(lang)
  File "/usr/lib64/python2.7/site-packages/bzrlib/i18n.py", line 114, in install_translations
    fallback=True)
  File "/usr/lib64/python2.7/gettext.py", line 556, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib64/python2.7/gettext.py", line 255, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.7/gettext.py", line 393, in _parse
    self.plural = c2py(plural)
  File "/usr/lib64/python2.7/gettext.py", line 177, in c2py
    result, nexttok = _parse(_tokenize(plural))
  File "/usr/lib64/python2.7/gettext.py", line 114, in _parse
    nexttok = next(tokens)
  File "/usr/lib64/python2.7/gettext.py", line 85, in _tokenize
    for mo in re.finditer(_token_pattern, plural):
  File "/usr/lib64/python2.7/re.py", line 190, in finditer
    return _compile(pattern, flags).finditer(string)
  File "/usr/lib64/python2.7/re.py", line 247, in _compile
    raise TypeError, "first argument must be string or compiled pattern"
TypeError: first argument must be string or compiled pattern

bzr 2.7.0 on python 2.7.13 (Linux-4.7.6-200.fc24.x86_64-x86_64-with-
    fedora-25-Twenty_Five)
arguments: ['/usr/bin/bzr', 'log', '--help']
plugins: bash_completion[2.7.0], changelog_merge[2.7.0], grep[2.7.0],
    launchpad[2.7.0], netrc_credential_store[2.7.0], news_merge[2.7.0],
    po_merge[2.7.0], weave_fmt[2.7.0]
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'en_GB.UTF-8'

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.



% bzr commit -m "make builddir: remove builddir if cmake fails"
bzr: ERROR: exceptions.TypeError: first argument must be string or compiled pattern

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 930, in exception_to_return_code
    return the_callable(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 1121, in run_bzr
    ret = run(*run_argv)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 673, in run_argv_aliases
    return self.run(**all_cmd_args)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commands.py", line 697, in run
    return self._operation.run_simple(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 136, in run_simple
    self.cleanups, self.func, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/builtins.py", line 3687, in run
    lossy=lossy)
  File "/usr/lib64/python2.7/site-packages/bzrlib/decorators.py", line 218, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/workingtree_4.py", line 218, in commit
    result = WorkingTree.commit(self, message, revprops, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/decorators.py", line 218, in write_locked
    result = unbound(self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/mutabletree.py", line 211, in commit
    *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commit.py", line 290, in commit
    lossy=lossy)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 132, in run
    self.cleanups, self.func, self, *args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/cleanup.py", line 166, in _do_with_cleanups
    result = func(*args, **kwargs)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commit.py", line 406, in _commit
    self._set_progress_stage("Collecting changes", counter=True)
  File "/usr/lib64/python2.7/site-packages/bzrlib/commit.py", line 989, in _set_progress_stage
    self._emit_progress()
  File "/usr/lib64/python2.7/site-packages/bzrlib/commit.py", line 998, in _emit_progress
    text = gettext("{0} [{1}] - Stage").format(self.pb_stage_name,
  File "/usr/lib64/python2.7/site-packages/bzrlib/i18n.py", line 40, in gettext
    install()
  File "/usr/lib64/python2.7/site-packages/bzrlib/i18n.py", line 92, in install
    _translations = install_translations(lang)
  File "/usr/lib64/python2.7/site-packages/bzrlib/i18n.py", line 114, in install_translations
    fallback=True)
  File "/usr/lib64/python2.7/gettext.py", line 556, in translation
    t = _translations.setdefault(key, class_(fp))
  File "/usr/lib64/python2.7/gettext.py", line 255, in __init__
    self._parse(fp)
  File "/usr/lib64/python2.7/gettext.py", line 393, in _parse
    self.plural = c2py(plural)
  File "/usr/lib64/python2.7/gettext.py", line 177, in c2py
    result, nexttok = _parse(_tokenize(plural))
  File "/usr/lib64/python2.7/gettext.py", line 114, in _parse
    nexttok = next(tokens)
  File "/usr/lib64/python2.7/gettext.py", line 85, in _tokenize
    for mo in re.finditer(_token_pattern, plural):
  File "/usr/lib64/python2.7/re.py", line 190, in finditer
    return _compile(pattern, flags).finditer(string)
  File "/usr/lib64/python2.7/re.py", line 247, in _compile
    raise TypeError, "first argument must be string or compiled pattern"
TypeError: first argument must be string or compiled pattern

bzr 2.7.0 on python 2.7.13 (Linux-4.7.6-200.fc24.x86_64-x86_64-with-
    fedora-25-Twenty_Five)
arguments: ['/usr/bin/bzr', 'commit', '-m', 'make builddir: remove builddir if
    cmake fails']
plugins: bash_completion[2.7.0], changelog_merge[2.7.0], grep[2.7.0],
    launchpad[2.7.0], netrc_credential_store[2.7.0], news_merge[2.7.0],
    po_merge[2.7.0], weave_fmt[2.7.0]
encoding: 'utf-8', fsenc: 'UTF-8', lang: 'en_GB.UTF-8'

*** Bazaar has encountered an internal error.  This probably indicates a
    bug in Bazaar.  You can help us fix it by filing a bug report at
        https://bugs.launchpad.net/bzr/+filebug
    including this traceback and a description of the problem.


Version-Release number of selected component (if applicable):

bzr-2.7.0-14.fc25.x86_64
python-2.7.13-1.fc25.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Set your locale to (for instance) en_GB.UTF-8
2. Run any bzr command

Actual results:

Ugly traceback

Expected results:

Functioning version control system

Additional info:

This appears to be this upstream bug, which is fixed in bzr 2.7.1:

Comment 1 Will Thompson 2017-01-27 08:05:51 UTC
Sorry, apparently I failed to paste the upstream bug URL: https://bugs.launchpad.net/bzr/+bug/1644003

Comment 2 Petr Stodulka 2017-01-27 12:39:04 UTC
Hi Will. It is already fixed and pushed for testing. In case the new build doesn't fix you problem, feel free to reopen the bug.

*** This bug has been marked as a duplicate of bug 1416571 ***


Note You need to log in before you can comment on or make changes to this bug.