Bug 141711 - No Devices Available with HP G85
No Devices Available with HP G85
Status: CLOSED DUPLICATE of bug 141527
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-12-02 22:04 EST by Chris
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-03 10:26:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris 2004-12-02 22:04:11 EST
Description of problem:
Printing works but no devices available using xsane with hpoj on HP
OfficeJet G85 

Version-Release number of selected component (if applicable):
$ rpm -qa | grep sane
xsane-0.92-13
sane-backends-1.0.14-6
xsane-gimp-0.92-13
sane-backends-devel-1.0.14-6
sane-frontends-1.0.12-4

How reproducible:
Always.

Steps to Reproduce:
1. Run xsane
2.
3.
  
Actual results:
No Devices Available

Expected results:
xsane should have found usb HP OfficeJet G85

Additional info:
export SANE_DEBUG_EPSON=128
scanimage > /tmp/scan.log 2>&1

scanimage: no SANE devices found
$ export SANE_DEBUG_EPSON=128
$
$ scanimage > /tmp/scan2.log 2>&1
$ cat /tmp/scan2.log
[sanei_debug] Setting debug level of epson to 128.
[epson] sane_init: sane-backends 1.0.14
[epson] sane_init, ># epson.conf<
[epson] sane_init, >#<
[epson] sane_init, ># here are some examples for how to configure the
EPSON backend<
[epson] sane_init, >#<
[epson] sane_init, ># SCSI scanner:<
[epson] sane_init, >scsi EPSON<
[epson] sane_init, >#<
[epson] sane_init, ># Parallel port scanner:<
[epson] sane_init, >#pio 0x278<
[epson] sane_init, >#pio 0x378<
[epson] sane_init, >#pio 0x3BC<
[epson] sane_init, >#<
[epson] sane_init, ># USB scanner:<
[epson] sane_init, ># There are two different methods of configuring a
USB scanner: libusb and the kernel module<
[epson] sane_init, ># For any system with libusb support (which is
pretty muchany recent Linux distribution) the<
[epson] sane_init, ># following line is sufficient. This however
assumes that the connected scanner (or to be more<
[epson] sane_init, ># accurate, it's device ID) is known to the backend.<
[epson] sane_init, >usb<
[epson] attach_one_usb()
[epson] SANE Epson Backend v0.2.41 - 2004-02-01
[epson] attach(, 3)
[epson] attach: opening
[epson] sane_init, ># For libusb support for unknown scanners use the
following command<
[epson] sane_init, ># usb <product ID> <device ID><
[epson] sane_init, ># e.g.:<
[epson] sane_init, ># usb 0x4b8 0x110<
[epson] sane_init, ># And for the scanner module, use the following
configuration:<
[epson] sane_init, >#usb /dev/usb/scanner0<
[epson] sane_init, >#usb /dev/usb/scanner0<
[epson] sane_init, ><
[epson] sane_init, ># Try USB printers -- this line is required (bug
#122328)<
[epson] sane_init, >usb<
[epson] attach_one_usb()
[epson] SANE Epson Backend v0.2.41 - 2004-02-01
[epson] attach(, 3)
[epson] attach: opening
[epson] sane_get_devices()
scanimage: no SANE devices found

$ /sbin/lsusb
Bus 001 Device 006: ID 03f0:0211 Hewlett-Packard
Bus 001 Device 001: ID 0000:0000

$ cat /etc/sane.d/dll.conf
# enable the next line if you want to allow access through the network:
net
abaton
agfafocus
apple
avision
artec
artec_eplus48u
as6e
bh
canon
canon630u
#canon_pp
coolscan
coolscan2
#dc25
#dc210
#dc240
dmc
epson
fujitsu
#gphoto2
gt68xx
hp
hpsj5s
hp5400
ibm
leo
ma1509
matsushita
microtek
microtek2
mustek
#mustek_pp
mustek_usb
nec
pie
pint
plustek
#plustek_pp
#pnm
qcam
ricoh
s9036
sceptre
sharp
sm3600
snapscan
sp15c
#st400
tamarack
teco1
teco2
teco3
#test
u12
umax
#umax_pp
umax1220u
v4l
#
# The following backends are not included in the sane-backends
distribution
# If you want to use them, download them from their webpages and read
their
# documentation
#
# HP OfficeJet backend homepage: http://hpoj.sf.net/
# Uncomment the following line if hpoj is installed:
hpoj
Comment 1 Tim Waugh 2004-12-03 04:55:45 EST
You need to install libsane-hpoj.
Comment 2 Chris 2004-12-03 09:33:29 EST
The FC3 install should have installed libsane-hpoj, right?
Comment 3 Tim Waugh 2004-12-03 10:26:49 EST
Not if you didn't select it.

*** This bug has been marked as a duplicate of 141527 ***

Note You need to log in before you can comment on or make changes to this bug.