Bug 1417135 - [Stress] : SHD Logs flooded with "Heal Failed" messages,filling up "/" quickly
Summary: [Stress] : SHD Logs flooded with "Heal Failed" messages,filling up "/" quickly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: disperse
Version: 3.10
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ashish Pandey
QA Contact:
URL:
Whiteboard:
Depends On: 1417050
Blocks: 1415583
TreeView+ depends on / blocked
 
Reported: 2017-01-27 09:40 UTC by Ashish Pandey
Modified: 2017-03-06 17:44 UTC (History)
11 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1417050
Environment:
Last Closed: 2017-03-06 17:44:28 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2017-01-30 07:13:46 UTC
REVIEW: https://review.gluster.org/16478 (cluster/ec: Change level of messages to DEBUG) posted (#1) for review on release-3.10 by Ashish Pandey (aspandey@redhat.com)

Comment 2 Worker Ant 2017-01-30 14:14:32 UTC
COMMIT: https://review.gluster.org/16478 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit feddaae9d4f796fc0f18a7a04cd6c41586876484
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Fri Jan 27 11:31:40 2017 +0530

    cluster/ec: Change level of messages to DEBUG
    
    Heal failed or passed should not be logged as warning.
    These can be observed from heal info if the heal is
    happening or not. If we require to debug a case where
    heal is not happening, we can set the level to DEBUG.
    
    >Change-Id: I347665c8c8b6223bb08a9f3dd5643a10ddc3b93e
    >BUG: 1417050
    >Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    >Reviewed-on: https://review.gluster.org/16473
    >Smoke: Gluster Build System <jenkins@build.gluster.org>
    >NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    >Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    >CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    >Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    
    Change-Id: I347665c8c8b6223bb08a9f3dd5643a10ddc3b93e
    BUG: 1417135
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: https://review.gluster.org/16478
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>

Comment 3 Shyamsundar 2017-03-06 17:44:28 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.