Bug 1417196 - Hosted engine setup stuck in installing engine from appliance
Summary: Hosted engine setup stuck in installing engine from appliance
Keywords:
Status: CLOSED DUPLICATE of bug 1409203
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Simone Tiraboschi
QA Contact: meital avital
URL:
Whiteboard: integration
Depends On:
Blocks: 1413928 1434957
TreeView+ depends on / blocked
 
Reported: 2017-01-27 13:34 UTC by Petr Matyáš
Modified: 2017-05-11 09:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-27 13:40:58 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Petr Matyáš 2017-01-27 13:34:02 UTC
Description of problem:
Hosted engine setup is stuck while trying to install engine from appliance with cloud-init.
Also when I tried to access the engine VMs root user, I got incorrect login even though I used the right password. I set only password and not ssh key and I set root accessible through ssh.

Version-Release number of selected component (if applicable):
4.1.0-9

How reproducible:
always

Steps to Reproduce:
1. install ovirt-hosted-engine-setup and run deploy
2. setup hosted engine according to values from attached answer file
3.

Actual results:
stuck on installing engine from appliance

Expected results:
correctly installed hosted engine

Additional info:
/var/log/messages is full of:
Jan 27 14:14:35 slot-9 journal: vdsm root ERROR failed to retrieve Hosted Engine HA info#012Traceback (most recent call last):#012  File
 "/usr/lib/python2.7/site-packages/vdsm/host/api.py", line 231, in _getHaInfo#012    stats = instance.get_all_stats()#012  File "/usr/li
b/python2.7/site-packages/ovirt_hosted_engine_ha/client/client.py", line 102, in get_all_stats#012    with broker.connection(self._retri
es, self._wait):#012  File "/usr/lib64/python2.7/contextlib.py", line 17, in __enter__#012    return self.gen.next()#012  File "/usr/lib
/python2.7/site-packages/ovirt_hosted_engine_ha/lib/brokerlink.py", line 99, in connection#012    self.connect(retries, wait)#012  File
"/usr/lib/python2.7/site-packages/ovirt_hosted_engine_ha/lib/brokerlink.py", line 78, in connect#012    raise BrokerConnectionError(erro
r_msg)#012BrokerConnectionError: Failed to connect to broker, the number of errors has exceeded the limit (1)
Jan 27 14:14:50 slot-9 journal: vdsm ovirt_hosted_engine_ha.lib.brokerlink.BrokerLink ERROR Failed to connect to broker, the number of e
rrors has exceeded the limit (1)

Comment 3 Simone Tiraboschi 2017-01-27 13:40:20 UTC
Could you please retry with ovirt-hosted-engine-setup-2.1.0.1 ?

Comment 4 Simone Tiraboschi 2017-01-27 13:40:58 UTC

*** This bug has been marked as a duplicate of bug 1409203 ***


Note You need to log in before you can comment on or make changes to this bug.