Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417228 - Missing repository on requirements
Summary: Missing repository on requirements
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: documentation
Version: 10.0 (Newton)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: async
: 10.0 (Newton)
Assignee: Charelle Collett
QA Contact: Martin Lopes
URL:
Whiteboard:
: 1420478 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-27 15:43 UTC by Yolanda Robla
Modified: 2020-03-11 15:40 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-23 04:10:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yolanda Robla 2017-01-27 15:43:29 UTC
Description of problem:


When looking through the documentation, i got a problem with the listed requirements:

https://access.redhat.com/documentation/en/red-hat-openstack-platform/10/paged/director-installation-and-usage/chapter-2-requirements

On a clean install, i was getting this error after installing with those repos:

Error: Package: 1:ceph-common-0.80.8-17.el7cp.x86_64 (rhel-7-server-rh-common-rpms)
            Requires: librbd1 = 1:0.80.8-17.el7cp
            Installed: 1:librbd1-0.94.5-1.el7.x86_64 (@rhel-7-server-rpms)
                librbd1 = 1:0.94.5-1.el7

I solved it by also adding the rhel-7-server-rhceph-2-tools-rpms

Ceph documentation also mentions that repo. So i think that this shall be added as a requirement for OpenStack, for the Ceph nodes.

Comment 1 Mike Burns 2017-01-30 14:46:18 UTC
Your error should not be happening if you have the repos listed enabled.  ceph-common is available in both rhel-7-server-rhceph-2-mon-rpms and rhel-7-server-rhceph-2-osd-rpms repositories.  

However, you're right.  For OSP 10 and forward, we do need to list rhel-7-server-rhceph-2-tools-rpms as a required overcloud repo.  The ceph-radosgw package comes from -tools.

Comment 3 Lucy Bopf 2017-02-21 00:53:43 UTC
Assigning to Charelle for review.

Comment 4 Lucy Bopf 2017-02-21 00:53:55 UTC
*** Bug 1420478 has been marked as a duplicate of this bug. ***

Comment 6 Martin Lopes 2017-02-21 04:05:38 UTC
Looks good to me. Merged.

Comment 9 Yolanda Robla 2017-03-14 15:23:40 UTC
Thanks, that looks better

Comment 11 Charelle Collett 2017-03-22 00:07:14 UTC
Backported to OSP 10


Note You need to log in before you can comment on or make changes to this bug.