Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417237 - Remove packages for monitoring after upgrading to Proxy 5.8 from old version
Summary: Remove packages for monitoring after upgrading to Proxy 5.8 from old version
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite Proxy 5
Classification: Red Hat
Component: Installer
Version: 580
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Gennadii Altukhov
QA Contact: Martin Korbel
URL:
Whiteboard:
Depends On:
Blocks: sat58-errata
TreeView+ depends on / blocked
 
Reported: 2017-01-27 16:13 UTC by Pavel Studeník
Modified: 2020-12-14 08:03 UTC (History)
6 users (show)

Fixed In Version: spacewalk-proxy-installer-2.5.0-12-sat
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1461096 (view as bug list)
Environment:
Last Closed: 2017-08-15 13:27:53 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:2474 0 normal SHIPPED_LIVE Red Hat Network Tools spacewalk-remote-utils bug fix and enhancement update 2017-08-15 17:26:58 UTC

Description Pavel Studeník 2017-01-27 16:13:20 UTC
Description of problem:
I had installed RHN Proxy with enabled Monitoring. In Satellite 5.8 the monitoring was removed. But after upgrade Proxy to 5.8. The packages are still installed  on the system. I supposed that all useless packages for monitoring will be removed. 

spacewalk-proxy-monitoring-2.0.1-1.el6sat.noarch
spacewalk-monitoring-selinux-2.2.1-1.el6sat.noarch

Version-Release number of selected component (if applicable):
spacewalk-proxy-installer-2.5.0-7.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1. install Proxy 5.7 with monitoring to Satellite 5.7
2. upgrade Satellite 5.7 to 5.8
3. upgrade Proxy to 5.8

Actual results:
packages were upgrade and monitoring is not removed

Expected results:
Monitoring is removed from system - disable services and remove packages

Comment 1 Pavel Studeník 2017-01-30 14:53:46 UTC
I installed two system RHN Proxy 5.7. One with enabled monitoring and one without. After upgrade to 5.8 I compared installed packages:

< eventReceivers-2.20.18-1.el6sat.noarch
< libapreq2-2.13-5.el6sat.x86_64
< MessageQueue-3.26.10-1.el6sat.noarch
< mod_perl-2.0.4-11.el6_5.x86_64
< nocpulse-common-2.2.9-1.el6sat.noarch
< nocpulse-db-perl-3.6.5-1.el6sat.noarch
< NOCpulsePlugins-2.209.7-1.el6sat.noarch
< NPalert-1.127.12-1.el6sat.noarch
< perl-BerkeleyDB-0.38-6.el6sat.x86_64
< perl-BSD-Resource-1.29.03-3.el6.x86_64
< perl-Class-MethodMaker-2.16-6.el6.x86_64
< perl-Class-Singleton-1.4-6.el6.noarch
< perl-Compress-Raw-Zlib-2.021-144.el6.x86_64
< perl-Compress-Zlib-2.021-144.el6.x86_64
< perl-Config-IniFiles-2.47-5.el6sat.noarch
< perl-Convert-BinHex-1.119-10.1.el6.noarch
< perl-Crypt-DES-2.05-10.el6sat.x86_64
< perl-Crypt-GeneratePassword-0.03-15.el6sat.noarch
< perl-Date-Manip-6.24-1.el6.noarch
< perl-DateTime-0.5300-3.el6.x86_64
< perl-Email-Date-Format-1.002-5.el6.noarch
< perl-FreezeThaw-0.45-5.el6.noarch
< perl-HTML-Parser-3.64-2.el6.x86_64
< perl-HTML-TableExtract-2.10-8.el6sat.noarch
< perl-HTML-Tagset-3.20-4.el6.noarch
< perl-IO-Compress-Base-2.021-144.el6.x86_64
< perl-IO-Compress-Zlib-2.021-144.el6.x86_64
< perl-IO-Socket-SSL-1.31-3.el6_8.2.noarch
< perl-IO-stringy-2.110-10.1.el6.noarch
< perl-libapreq2-2.13-5.el6sat.x86_64
< perl-libwww-perl-5.833-5.el6.noarch
< perl-List-MoreUtils-0.22-10.el6.x86_64
< perl-MailTools-2.04-4.el6.noarch
< perl-MIME-Lite-3.027-2.el6.noarch
< perl-MIME-tools-5.427-4.el6.noarch
< perl-MIME-Types-1.28-2.el6.noarch
< perl-Net-IPv4Addr-0.10-7.el6sat.noarch
< perl-Net-LibIDN-0.12-3.el6.x86_64
< perl-Net-SNMP-6.0.1-3.el6sat.noarch
< perl-Net-SSLeay-1.35-10.el6_8.1.x86_64
< perl-NOCpulse-CLAC-1.9.9-1.el6sat.noarch
< perl-NOCpulse-Debug-1.23.17-1.el6sat.noarch
< perl-NOCpulse-Gritch-2.2.1-1.el6sat.noarch
< perl-NOCpulse-Object-1.26.12-1.el6sat.noarch
< perl-NOCpulse-OracleDB-1.28.27-1.el6sat.noarch
< perl-NOCpulse-PersistentConnection-1.10.1-1.el6sat.noarch
< perl-NOCpulse-Probe-1.184.18-1.el6sat.noarch
< perl-NOCpulse-ProcessPool-1.6.1-1.el6sat.noarch
< perl-NOCpulse-SetID-1.7.2-1.el6sat.noarch
< perl-NOCpulse-Scheduler-1.58.12-1.el6sat.noarch
< perl-NOCpulse-Utils-1.14.12-1.el6sat.noarch
< perl-SOAP-Lite-0.710.10-4.el6.noarch
< perl-Socket6-0.23-4.el6.x86_64
< perl-TimeDate-1.16-13.el6.noarch
< perl-Time-HiRes-1.9721-144.el6.x86_64
< perl-URI-1.40-2.el6.noarch
< perl-XML-DOM-1.44-7.el6.noarch
< perl-XML-Dumper-0.81-8.el6.noarch
< perl-XML-Generator-1.01-6.el6sat.noarch
< perl-XML-Parser-2.36-7.el6.x86_64
< perl-XML-RegExp-0.03-7.el6.noarch
< perl-YAML-Syck-1.07-4.el6.x86_64
< ProgAGoGo-1.11.6-1.el6sat.noarch
< SatConfig-bootstrap-server-1.13.5-1.el6sat.noarch
< SatConfig-bootstrap-1.11.5-1.el6sat.noarch
< SatConfig-cluster-2.2.2-1.el6sat.noarch
< SatConfig-general-1.216.31-1.el6sat.noarch
< SatConfig-generator-2.29.14-1.el6sat.noarch
< SatConfig-installer-3.24.6-1.el6sat.noarch
< SatConfig-spread-1.1.3-1.el6sat.noarch
< scdb-1.15.8-1.el6sat.noarch
< SNMPAlerts-0.5.7-1.el6sat.noarch
< spacewalk-monitoring-selinux-2.2.1-1.el6sat.noarch
< spacewalk-proxy-monitoring-2.0.1-1.el6sat.noarch
< SputLite-client-1.10.1-1.el6sat.noarch
< SputLite-server-1.10.1-1.el6sat.noarch
< ssl_bridge-1.9.3-1.el6sat.noarch
< status_log_acceptor-0.12.11-1.el6sat.noarch
< tsdb-1.27.29-1.el6sat.noarch

And differences in /etc:

+#	NOCpulse.ini
+#	cron.d/notification
+#	ha.d/
+#	logrotate.d/nocpulse-common
+#	nocpulse/
+#	notification/
+#	rc.d/init.d/MonitoringScout
+#	rc.d/init.d/tsdb_local_queue
+#	rc.d/np.d/
+#	rc.d/rc0.d/K14MonitoringScout
+#	rc.d/rc1.d/K14MonitoringScout
+#	rc.d/rc2.d/K14MonitoringScout
+#	rc.d/rc3.d/S86MonitoringScout
+#	rc.d/rc4.d/S86MonitoringScout
+#	rc.d/rc5.d/S86MonitoringScout
+#	rc.d/rc6.d/K14MonitoringScout
+#	satname
+#	selinux/targeted/modules/active/modules/spacewalk-monitoring.pp
+#	smrsh/

Comment 2 Tomas Lestach 2017-01-30 15:06:51 UTC
Expected behavior is to uninstall unneeded monitoring packages (and their dependencies?).
We're definitely not going to remove nocpulse user, log files, or any other configuration files not owned by rpm.

Comment 3 Pavel Studeník 2017-01-30 15:12:24 UTC
It depends what is expected behavior. I think that the first good step is removing packages with monitoring and disable this services.

Comment 6 Pavel Studeník 2017-05-25 15:39:37 UTC
After ugrade to Proxy 5.8 the packages spacewalk-monitoring-selinux.noarch and spacewalk-monitoring.noarch were removed. 

Verified spacewalk-proxy-installer-2.5.0-9.el6sat.noarch

Comment 14 Tomas Lestach 2017-07-11 12:34:27 UTC
Candace, check bug 1461096. That one addresses a similar problem on the server.

Comment 22 Martin Korbel 2017-08-11 09:40:24 UTC
VERIFIED on spacewalk-proxy-installer-2.5.0-12

> rpm -q $(cat monitoring-packages.txt) | grep -c -v installed
0

Comment 24 errata-xmlrpc 2017-08-15 13:27:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2474


Note You need to log in before you can comment on or make changes to this bug.