Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1417395 - [RFE] Upgrade with OpenShift running on top of OpenStack non-disruptively
Summary: [RFE] Upgrade with OpenShift running on top of OpenStack non-disruptively
Keywords:
Status: CLOSED DUPLICATE of bug 1437322
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: Angus Thomas
QA Contact: Omri Hochman
URL:
Whiteboard:
Depends On:
Blocks: 1389435 1394885
TreeView+ depends on / blocked
 
Reported: 2017-01-28 17:33 UTC by arkady kanevsky
Modified: 2017-06-05 17:53 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-06 20:06:50 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description arkady kanevsky 2017-01-28 17:33:10 UTC
Description of problem:
Provide upgrade of OpenStack with Openshift layered on top using cinder for storage non-disruptively. That means that applications and development being done in openshift is not impacted at all during openstack upgrade.

Expect that this BZ will be broken into several smaller once we identify the root causes of disruptions. Let's start with the scenario where no new VMs created for openshift during upgrade of openstack.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 arkady kanevsky 2017-01-28 17:37:03 UTC
Sean,
as usual leave to you what is the right component to target it for.
Also who are the right people on openshift side who should be on cc list.

Comment 2 Sean Merrow 2017-01-30 21:06:34 UTC
In Reply to:
> Expect that this BZ will be broken into several smaller once we identify the 
> root causes of disruptions.


Hi Arkady,

Just so we are clear on the ask here, is it for one of the following three, or something else?

1) is this something that our software does not allow for today, and you are requesting a new feature be developed to so it can be done? 
2) are you saying that the software should allow for it today, but it doesn't work and the root cause of the failures need to be identified and fixed?
3) is the request just that our QE team validate it in the lab?

Thanks,
Sean

Comment 3 Jaromir Coufal 2017-02-06 20:06:50 UTC
Hi Arkady,

this seems as a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=1396538 which is talking about impact of workloads - services in general. Can we keep track on that one only?

Closing this one as duplicate for one, please re-open if we there is some misunderstanding.

*** This bug has been marked as a duplicate of bug 1396538 ***

Comment 4 Stephen Gordon 2017-02-06 22:03:19 UTC
(In reply to Jaromir Coufal from comment #3)
> Hi Arkady,
> 
> this seems as a duplicate of
> https://bugzilla.redhat.com/show_bug.cgi?id=1396538 which is talking about
> impact of workloads - services in general. Can we keep track on that one
> only?
> 
> Closing this one as duplicate for one, please re-open if we there is some
> misunderstanding.
> 
> *** This bug has been marked as a duplicate of bug 1396538 ***

Unfortunately I think 1396538 is marked private, so the Dell folks can't see it.

Comment 5 Jaromir Coufal 2017-03-30 05:06:26 UTC
Needed to re-shuffle BZs to create publicly visible EPIC tracking BZ. Updated now.

*** This bug has been marked as a duplicate of bug 1437322 ***

Comment 6 arkady kanevsky 2017-06-05 17:53:23 UTC
Yes.
This BZ is the subset of bug 1437322 .
It only minimize impact on OpenShift running during OpenStack upgrade under it.

But this BZ was about integrated upgrade that upgrades OpenShift and OpenStack at the same time.


Note You need to log in before you can comment on or make changes to this bug.