Bug 1417402 - automatic split resolution with size as policy should not work on a directory which is in metadata splitbrain
Summary: automatic split resolution with size as policy should not work on a director...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: replicate
Version: rhgs-3.2
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Sheetal Pamecha
QA Contact: Nag Pavan Chilakam
URL:
Whiteboard:
Depends On:
Blocks: 1304593 1655050
TreeView+ depends on / blocked
 
Reported: 2017-01-28 18:14 UTC by Nag Pavan Chilakam
Modified: 2018-11-30 12:24 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1655050 (view as bug list)
Environment:
Last Closed: 2018-11-16 05:48:28 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nag Pavan Chilakam 2017-01-28 18:14:58 UTC
Description of problem:
=====================
when a directory is in metadata splitbrain,and split brain resolution is set to size, then we must not be automatically healing this file as there is no significant information to choose size as the option as the directories will be of same size

Version-Release number of selected component (if applicable):

3.8.-4-13

How reproducible:
always

Steps to Reproduce:
1.create a x2 volume spanning on two nodes
2.mount on clients as below
c1 sees on n1
c2 only sees n2
c3 sees n1 and n2
3.now set fav child policy to size
4. create dir say dir1 from c3
5. disable self heal deamon
6. do a chmod of dir1 to say 0000 from c1
7. do a chmod of dir1 to say 0777 from c2
8. check heal info , must show dir1 as in splitbrain
9. now enable heal and trigger heal


Actual results:
=============
dir is getting resolved of splitbrain

Expected results:
==================
as size is the policy, split brain resolution must not work in this case as the size per-se is same. it should be splitbrain and let the admin takeup the stand on how to resolve it either through backend or manually thorugh cli

Additional info:

Comment 5 Atin Mukherjee 2018-11-11 21:58:15 UTC
This BZ hasn't received any updates since when it has reported. Are we going to work on this bug in coming months? Can we have a decision on this bug?


Note You need to log in before you can comment on or make changes to this bug.