Bug 1655050 - automatic split resolution with size as policy should not work on a directory which is in metadata splitbrain
Summary: automatic split resolution with size as policy should not work on a director...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: replicate
Version: mainline
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Sheetal Pamecha
QA Contact:
URL:
Whiteboard:
Depends On: 1417402
Blocks: 1304593
TreeView+ depends on / blocked
 
Reported: 2018-11-30 12:24 UTC by Sheetal Pamecha
Modified: 2019-03-25 16:32 UTC (History)
8 users (show)

Fixed In Version: glusterfs-6.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1417402
Environment:
Last Closed: 2019-01-21 04:25:02 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Gluster.org Gerrit 21767 None Merged afr: Splitbrain with size as policy must not resolve for directory 2019-01-21 04:25:01 UTC

Comment 1 Worker Ant 2018-11-30 14:36:08 UTC
REVIEW: https://review.gluster.org/21767 (afr: Splitbrain with size as policy must not resolve for directory) posted (#1) for review on master by Sheetal Pamecha

Comment 2 Worker Ant 2019-01-21 04:25:02 UTC
REVIEW: https://review.gluster.org/21767 (afr: Splitbrain with size as policy must not resolve for directory) merged (#7) on master by Amar Tumballi

Comment 3 Shyamsundar 2019-03-25 16:32:19 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-6.0, please open a new bug report.

glusterfs-6.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2019-March/000120.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.