Bug 1417431 - Mesa upgrade to version 13.0.3-4.fc25 fails - missing dependencies
Summary: Mesa upgrade to version 13.0.3-4.fc25 fails - missing dependencies
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1417672 1417793 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-29 09:34 UTC by Steve Bryant
Modified: 2017-03-01 14:32 UTC (History)
33 users (show)

Fixed In Version: mesa-13.0.3-5.fc25
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-01-31 00:48:35 UTC
Type: Bug


Attachments (Terms of Use)

Description Steve Bryant 2017-01-29 09:34:23 UTC
Description of problem:
Upgrade of various mesa packages from 13.0.3-1.fc25 to 13.0.3-4.fc25 fails due to missing dependencies on "libglvnd-glx(x86-32)" and "libglvnd-glx(x86-64)":

# dnf upgrade
Last metadata expiration check: 0:43:38 ago on Sun Jan 29 08:36:07 2017.
Dependencies resolved.
================================================================================
 Package                  Arch         Version              Repository     Size
================================================================================
Skipping packages with broken dependencies:
 mesa-libEGL              i686         13.0.3-4.fc25        updates       105 k
 mesa-libEGL              x86_64       13.0.3-4.fc25        updates       103 k
 mesa-libEGL-devel        x86_64       13.0.3-4.fc25        updates        38 k
 mesa-libGL               i686         13.0.3-4.fc25        updates       181 k
 mesa-libGL               x86_64       13.0.3-4.fc25        updates       164 k
 mesa-libGL-devel         x86_64       13.0.3-4.fc25        updates       161 k
 mesa-libGLES             x86_64       13.0.3-4.fc25        updates        21 k
 mesa-libGLES-devel       x86_64       13.0.3-4.fc25        updates        62 k
 mesa-libOSMesa           i686         13.0.3-4.fc25        updates       2.0 M
 mesa-libOSMesa           x86_64       13.0.3-4.fc25        updates       1.9 M
 mesa-libglapi            i686         13.0.3-4.fc25        updates        59 k
 mesa-libglapi            x86_64       13.0.3-4.fc25        updates        49 k

Transaction Summary
================================================================================
Skip  12 Packages

# dnf repoquery --whatprovides 'libglvnd-egl(x86-64)'
Last metadata expiration check: 0:52:59 ago on Sun Jan 29 08:36:07 2017.
#

Version-Release number of selected component (if applicable):
(See above)

How reproducible:
Run "dnf upgrade when mesa packages at 13.0.3-1.fc25 are installed.

Steps to Reproduce:
1.
2.
3.

Actual results:
Upgrade to various Mesa packages fail with "broken dependencies".

Expected results:
Upgrade proceeds without error.

Additional info:

Comment 1 Steve Bryant 2017-01-29 09:55:06 UTC
Enabling repo "updates-testing" allows Mesa to be upgraded by providing the mssing "libglvnd" packages:

# dnf --enablerepo updates-testing upgrade mesa-\*
Last metadata expiration check: 0:01:12 ago on Sun Jan 29 09:51:03 2017.
Dependencies resolved.
================================================================================
 Package             Arch   Version                       Repository       Size
================================================================================
Installing:
 libglvnd-core-devel x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  19 k
 libglvnd-devel      x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  11 k
 libglvnd-egl        i686   1:0.2.999-7.gitdc16f8c.fc25   updates-testing  43 k
 libglvnd-egl        x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  42 k
 libglvnd-gles       x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  30 k
 libglvnd-glx        i686   1:0.2.999-7.gitdc16f8c.fc25   updates-testing 118 k
 libglvnd-glx        x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing 124 k
 libglvnd-opengl     x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  43 k
Upgrading:
 libglvnd            i686   1:0.2.999-7.gitdc16f8c.fc25   updates-testing  82 k
 libglvnd            x86_64 1:0.2.999-7.gitdc16f8c.fc25   updates-testing  88 k
 mesa-libEGL         i686   13.0.3-4.fc25                 updates         105 k
 mesa-libEGL         x86_64 13.0.3-4.fc25                 updates         103 k
 mesa-libEGL-devel   x86_64 13.0.3-4.fc25                 updates          38 k
 mesa-libGL          i686   13.0.3-4.fc25                 updates         181 k
 mesa-libGL          x86_64 13.0.3-4.fc25                 updates         164 k
 mesa-libGL-devel    x86_64 13.0.3-4.fc25                 updates         161 k
 mesa-libGLES        x86_64 13.0.3-4.fc25                 updates          21 k
 mesa-libGLES-devel  x86_64 13.0.3-4.fc25                 updates          62 k
 mesa-libOSMesa      i686   13.0.3-4.fc25                 updates         2.0 M
 mesa-libOSMesa      x86_64 13.0.3-4.fc25                 updates         1.9 M
 mesa-libglapi       i686   13.0.3-4.fc25                 updates          59 k
 mesa-libglapi       x86_64 13.0.3-4.fc25                 updates          49 k

Transaction Summary
================================================================================
Install   8 Packages
Upgrade  14 Packages

Total download size: 5.4 M

Comment 2 Volker Braun 2017-01-29 21:08:01 UTC
I just updated fedora 24 -> 25 and X would not start any more. Only after installing the missing dependencies from updates-testing does X start again.

Comment 3 Andy Richardson 2017-01-29 22:45:00 UTC
I can confirm the same issue here. The dependencies need to be made available on the update repo.

Comment 4 Woi 2017-01-29 23:25:43 UTC
Volker, Andy: Have you tried a distro-sync as suggested in the System Upgrade documentation <http://fedoraproject.org/wiki/DNF_system_upgrade>?

Comment 5 Volker Braun 2017-01-29 23:43:00 UTC
I didn't use distro-sync, possibly that would have fixed the issue too. Though there was no indication that anything is wrong during the update process, it was all smooth sailing until the reboot and then X didn't start (and the auto-restarting gdm prevented me initially from logging in on the console, but that does stop after a while)

Comment 6 David Bolding 2017-01-30 01:21:10 UTC
FWIW, I had the same issue; broken dependencies on EGL packages, which prevented the graphical environment from starting.  Neither distro-sync not update --best --allowerasing fixed the problem, but enabling updates-testing fixed it.

After the the dnf-update and reboot that broke my system, I also noticed that the SElabels on my home directory were wrong.  I think that can happen if an rpmoperation fails, so that might be related?

Comment 7 Paul DeStefano 2017-01-30 05:21:29 UTC
Wow, I'm feeling very lucky to have searched this before I let my system continue the upgrade without these broken packages.  Two questions:

1) You had a working system, up-to-date recently, and then you did dnf upgrade, and then X11 as completely broken?  Is that right?  So now is it possible that DNF broke the system if it *didn't* install packages for which the dependencies couldn't be fulfilled?  Does that mean that other packages were missing the proper dependencies that should have also been held back, but weren't?

2) How do these dependencies end up in updates-testing while the dependents pass on to updates without them?

Comment 8 Volker Braun 2017-01-30 08:13:33 UTC
For the record, I did have an up-to-date Fedora 24 system before updating. After updating, I had a mix of mesa rpm package versions and got the following crash in Xorg.log:

[  1608.095] (EE) Backtrace:
[  1608.096] (EE) 0: /usr/libexec/Xorg (OsLookupColor+0x139) [0x59e8e9]
[  1608.096] (EE) 1: /lib64/libpthread.so.0 (__restore_rt+0x0) [0x7f69975c45bf]
[  1608.096] (EE) 2: /lib64/libEGL.so.1 (eglCreateSync+0xedd9) [0x7f698a2a5269]
[  1608.097] (EE) 3: /lib64/libEGL.so.1 (eglCreateSync+0x71a5) [0x7f698a295c25]
[  1608.097] (EE) 4: /lib64/libEGL.so.1 (eglCreateSync+0x3d05) [0x7f698a28f2e5]
[  1608.097] (EE) 5: /lib64/libEGL.so.1 (eglCreateSync+0x3dc9) [0x7f698a28f519]
[  1608.097] (EE) 6: /lib64/libEGL.so.1 (eglInitialize+0xe2) [0x7f698a2864e2]
[  1608.097] (EE) 7: /usr/lib64/xorg/modules/libglamoregl.so (glamor_egl_init+0x109) [0x7f6991b2e029]
[  1608.098] (EE) 8: /usr/lib64/xorg/modules/drivers/radeon_drv.so (_init+0x4a276) [0x7f6992a51396]
[  1608.098] (EE) 9: /usr/lib64/xorg/modules/drivers/radeon_drv.so (_init+0x3f0db) [0x7f6992a3a60b]
[  1608.098] (EE) 10: /usr/libexec/Xorg (InitOutput+0xac2) [0x47d742]
[  1608.098] (EE) 11: /usr/libexec/Xorg (InitFonts+0x216) [0x43ae46]
[  1608.099] (EE) 12: /lib64/libc.so.6 (__libc_start_main+0xf1) [0x7f699720d401]
[  1608.099] (EE) 13: /usr/libexec/Xorg (_start+0x2a) [0x424cfa]
[  1608.100] (EE) 14: ? (?+0x2a) [0x2a]
[  1608.100] (EE) 
[  1608.100] (EE) Segmentation fault at address 0x0
[  1608.100] (EE) 
Fatal server error:
[  1608.100] (EE) Caught signal 11 (Segmentation fault). Server aborting

Comment 9 clplaza23 2017-01-30 14:03:09 UTC
Just as an additional feedback, this heavily affects fresh installs and new users. Yesterday I spent a whole lot of time thinking why my system suddenly stopped working after the first update done via store.

I just realized the dependency problem after doing everything manually and noticing the missing dependency.

After fixing it with the suggested workaround, the system works well, but I'm unable to install software which has mesa dependency. For example, Wine won't install unless I set it to be installed from the "updates-testing".

See where this is going? It's 2017 already and I can feel the dependency hell starting.

Comment 10 Andy Richardson 2017-01-30 14:40:18 UTC
This issue should effect everyone with the mesa packages installed. Distro-sync won't/hasn't make a difference; either the mesa package update has the incorrect dependencies or the dependencies in question should have been pushed to the update repository alongside the latest mesa package.

If necessary, I can test if this issue persists inside a fresh install (Docker container) but it seems as though we already have confirmation that this is the case.

Comment 11 Igor Gnatenko 2017-01-30 15:55:17 UTC
*** Bug 1417672 has been marked as a duplicate of this bug. ***

Comment 12 M. Edward (Ed) Borasky 2017-01-30 19:22:36 UTC
(In reply to clplaza23 from comment #9)
> Just as an additional feedback, this heavily affects fresh installs and new
> users. Yesterday I spent a whole lot of time thinking why my system suddenly
> stopped working after the first update done via store.
> 
> I just realized the dependency problem after doing everything manually and
> noticing the missing dependency.
> 
> After fixing it with the suggested workaround, the system works well, but
> I'm unable to install software which has mesa dependency. For example, Wine
> won't install unless I set it to be installed from the "updates-testing".
> 
> See where this is going? It's 2017 already and I can feel the dependency
> hell starting.

I have a system that's been running just fine with F25 (updates-testing *enabled*). I did an upgrade the other day and it no longer booted up. I *think* it's the same bug; I re-installed from the F25 workstation media, did a full update and the machine no longer came up. I finally ended up doing a reinstall from the 20 January Workstation respin and selectively updating from there package by package, skipping the Mesa stuff.

So ... how do I tell when it's safe to let the Mesa packages install? Am I safer with or without updates-testing enabled?

Comment 13 Seppo Yli-Olli 2017-01-30 21:27:21 UTC
Under no circumstances enable updates-testing. It's entirely possible the libglvnd will be rolled back which will make the next upgrade more painful to you. Just wait until situation resolves by itself

Comment 14 Gary Gatling 2017-01-30 21:30:19 UTC
At least one user is reporting that the mesa packages from updates-testing broke bumblebee for them. 

I was going to test myself but on my optimus test system freshly installed today with no bumblebee and mesa-*-13.0.3-4.fc25 gdm refuses to start.

http://i.imgur.com/q3qmCiB.jpg

Comment 15 M. Edward (Ed) Borasky 2017-01-30 21:39:08 UTC
(In reply to Seppo Yli-Olli from comment #13)
> Under no circumstances enable updates-testing. It's entirely possible the
> libglvnd will be rolled back which will make the next upgrade more painful
> to you. Just wait until situation resolves by itself

How do I know when it has resolved itself though? Is it even safe to do the update "Software" keeps bugging me to do?

Comment 16 Fedora Update System 2017-01-30 21:41:21 UTC
mesa-13.0.3-5.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2017-0d59b99f18

Comment 17 Seppo Yli-Olli 2017-01-30 21:57:57 UTC
(In reply to M. Edward (Ed) Borasky from comment #15)
> (In reply to Seppo Yli-Olli from comment #13)
> > Under no circumstances enable updates-testing. It's entirely possible the
> > libglvnd will be rolled back which will make the next upgrade more painful
> > to you. Just wait until situation resolves by itself
> 
> How do I know when it has resolved itself though? Is it even safe to do the
> update "Software" keeps bugging me to do?

The situation has resolved itself when you can update without enabling updates-testing which should happen once above package hits stable. The migration path from system without libglvnd to one without may be potentially painful so waiting is the best option at the moment.

Comment 18 Doug Maxey 2017-01-30 22:40:47 UTC
(In reply to Seppo Yli-Olli from comment #17)
...
> migration path from system without libglvnd to one without may be
> potentially painful so waiting is the best option at the moment.

On at least one occasion after rolling a system from probably f14 forward, removal and reinstall of the offending package was a quick fix.
 
ahem :)

dnf remove mesa-libGL-13.0.3-1.fc25
...
Transaction Summary
===============================================================================
Remove  908 Packages

I think I will wait for the update on this one.

Comment 19 Fedora Update System 2017-01-31 00:48:35 UTC
mesa-13.0.3-5.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Tomas Toth 2017-01-31 08:10:53 UTC
The mesa 13.0.3-5.fc25 update creates a new issue for those of us, who worked around the (13.0.3-4) dependency issue by enabling updates-testing, got libglvnd-* installed.

The new mesa 13.0.3-5.fc25 conflicts with libglvnd-*, see below, and half the system depends on ibglvnd-*.

# dnf update
Last metadata expiration check: 0:42:16 ago on Tue Jan 31 08:23:53 2017.
Dependencies resolved.
===========================================================================
 Package                 Arch       Version              Repository   Size
===========================================================================
Upgrading:
 mesa-dri-drivers        x86_64     13.0.3-5.fc25        updates      11 M
 mesa-filesystem         x86_64     13.0.3-5.fc25        updates      24 k
 mesa-libEGL             x86_64     13.0.3-5.fc25        updates     101 k
 mesa-libGL              x86_64     13.0.3-5.fc25        updates     163 k
 mesa-libGLES            x86_64     13.0.3-5.fc25        updates      33 k
 mesa-libOSMesa          x86_64     13.0.3-5.fc25        updates     1.9 M
 mesa-libOpenCL          x86_64     13.0.3-5.fc25        updates     579 k
 mesa-libgbm             x86_64     13.0.3-5.fc25        updates      42 k
 mesa-libglapi           x86_64     13.0.3-5.fc25        updates      49 k
 mesa-libwayland-egl     x86_64     13.0.3-5.fc25        updates      25 k
 mesa-libxatracker       x86_64     13.0.3-5.fc25        updates     1.4 M
 mesa-vdpau-drivers      x86_64     13.0.3-5.fc25        updates     1.8 M

Transaction Summary
===========================================================================
Upgrade  12 Packages

Total size: 17 M
Is this ok [y/N]: y
Downloading Packages:
[SKIPPED] mesa-dri-drivers-13.0.3-5.fc25.x86_64.rpm: Already downloaded   
[SKIPPED] mesa-filesystem-13.0.3-5.fc25.x86_64.rpm: Already downloaded    
[SKIPPED] mesa-vdpau-drivers-13.0.3-5.fc25.x86_64.rpm: Already downloaded 
[SKIPPED] mesa-libEGL-13.0.3-5.fc25.x86_64.rpm: Already downloaded        
[SKIPPED] mesa-libGL-13.0.3-5.fc25.x86_64.rpm: Already downloaded         
[SKIPPED] mesa-libglapi-13.0.3-5.fc25.x86_64.rpm: Already downloaded      
[SKIPPED] mesa-libOSMesa-13.0.3-5.fc25.x86_64.rpm: Already downloaded     
[SKIPPED] mesa-libGLES-13.0.3-5.fc25.x86_64.rpm: Already downloaded       
[SKIPPED] mesa-libOpenCL-13.0.3-5.fc25.x86_64.rpm: Already downloaded     
[SKIPPED] mesa-libgbm-13.0.3-5.fc25.x86_64.rpm: Already downloaded        
[SKIPPED] mesa-libwayland-egl-13.0.3-5.fc25.x86_64.rpm: Already downloaded
[SKIPPED] mesa-libxatracker-13.0.3-5.fc25.x86_64.rpm: Already downloaded  
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/libEGL.so.1.0.0 from install of mesa-libEGL-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib64/libGL.so.1 from install of mesa-libGL-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-glx-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib64/libGLESv2.so.2.0.0 from install of mesa-libGLES-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-gles-1:0.2.999-7.gitdc16f8c.fc25.x86_64

Error Summary
-------------

Comment 21 Simone 2017-01-31 08:39:51 UTC
I report that after a # dnf distro-sync (see logs below) I wasn't able to login (X not starting?) and it was impossible to use my laptop. To solve I had to update the system with # dnf --enablerepo updates-testing upgrade mesa-* from liveUSB.

I think that such problems should be avoided... 

Codice di uscita    : Completato
Linea di comando   : distro-sync
Transazione eseguita con:
    Installati            dnf-1.1.10-5.fc25.noarch @updates
    Installati            rpm-4.13.0-6.fc25.x86_64 @updates
Pacchetti modificati:
    A versione precedente mesa-libEGL-12.0.3-3.fc25.i686      @fedora
    A versione precedente mesa-libEGL-12.0.3-3.fc25.x86_64    @fedora
    A versione precedente             13.0.3-1.fc25.i686      @updates
    A versione precedente             13.0.3-1.fc25.x86_64    @updates
    A versione precedente mesa-libGL-12.0.3-3.fc25.i686       @fedora
    A versione precedente mesa-libGL-12.0.3-3.fc25.x86_64     @fedora
    A versione precedente            13.0.3-1.fc25.i686       @updates
    A versione precedente            13.0.3-1.fc25.x86_64     @updates
    A versione precedente mesa-libGLES-12.0.3-3.fc25.x86_64   @fedora
    A versione precedente              13.0.3-1.fc25.x86_64   @updates
    A versione precedente mesa-libOSMesa-12.0.3-3.fc25.x86_64 @fedora
    A versione precedente                13.0.3-1.fc25.x86_64 @updates
    A versione precedente mesa-libglapi-12.0.3-3.fc25.i686    @fedora
    A versione precedente mesa-libglapi-12.0.3-3.fc25.x86_64  @fedora
    A versione precedente               13.0.3-1.fc25.i686    @updates
    A versione precedente               13.0.3-1.fc25.x86_64  @updates

Comment 22 Gurenko Alex 2017-01-31 09:11:53 UTC
@Tomas Toth
 I had same issue, I did dnf history unde #num (the transaction where I used test repo) and then dnf update. That worked for me.

Comment 23 Paul DeStefano 2017-01-31 09:40:06 UTC
I don't think the issue is closed.

The error reported here is that packages were published that made it to updates that were broken *beyond* what DNF could handle.  That's this bug and nothing in the bug suggests it was fixed.  Publishing a fixed package is good, but, that's not the root cause of this bug.

Case and point: guidance was distributed on this bug to get the needed packages--rpms needed by *official published* pacakges--and that was not contradicted until much later.  Clearly this bug has not been addressed.

Pkg maintainers must give instructions to people who packages from updates-testing.  Is comment 22 right?  I don't know.  I could be another error where DNF thinks that is a valid action, but it isn't.  I don't know anymore.

If someone made a mistake, fine, no big deal; just say so.  Otherwise, you're saying that DNF could break systems at any moment and no effort whatsoever is being made to prevent that and I know that's not the case.

Comment 24 David Novák 2017-01-31 09:41:41 UTC
(In reply to Gurenko Alex from comment #22)
> @Tomas Toth
>  I had same issue, I did dnf history unde #num (the transaction where I used
> test repo) and then dnf update. That worked for me.

I got:
Undoing transaction 192, from Mon Jan 30 10:53:45 2017
    Upgraded mesa-libEGL-13.0.3-1.fc25.i686                         @updates
    Upgraded mesa-libEGL-13.0.3-1.fc25.x86_64                       @updates
    Upgrade              13.0.3-4.fc25.i686                         @updates
    Upgrade              13.0.3-4.fc25.x86_64                       @updates
    Upgraded mesa-libEGL-devel-13.0.3-1.fc25.x86_64                 @updates
    Upgrade                    13.0.3-4.fc25.x86_64                 @updates
    Upgraded mesa-libGL-13.0.3-1.fc25.i686                          @updates
    Upgraded mesa-libGL-13.0.3-1.fc25.x86_64                        @updates
    Upgrade             13.0.3-4.fc25.i686                          @updates
    Upgrade             13.0.3-4.fc25.x86_64                        @updates
    Upgraded mesa-libGL-devel-13.0.3-1.fc25.x86_64                  @updates
    Upgrade                   13.0.3-4.fc25.x86_64                  @updates
    Upgraded mesa-libGLES-13.0.3-1.fc25.x86_64                      @updates
    Upgrade               13.0.3-4.fc25.x86_64                      @updates
    Upgraded mesa-libglapi-13.0.3-1.fc25.i686                       @updates
    Upgraded mesa-libglapi-13.0.3-1.fc25.x86_64                     @updates
    Upgrade                13.0.3-4.fc25.i686                       @updates
    Upgrade                13.0.3-4.fc25.x86_64                     @updates
    Install  libglvnd-1:0.2.999-7.gitdc16f8c.fc25.i686              @updates-testing
    Install  libglvnd-1:0.2.999-7.gitdc16f8c.fc25.x86_64            @updates-testing
    Install  libglvnd-core-devel-1:0.2.999-7.gitdc16f8c.fc25.x86_64 @updates-testing
    Install  libglvnd-devel-1:0.2.999-7.gitdc16f8c.fc25.x86_64      @updates-testing
    Install  libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.i686          @updates-testing
    Install  libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.x86_64        @updates-testing
    Install  libglvnd-gles-1:0.2.999-7.gitdc16f8c.fc25.x86_64       @updates-testing
    Install  libglvnd-glx-1:0.2.999-7.gitdc16f8c.fc25.i686          @updates-testing
    Install  libglvnd-glx-1:0.2.999-7.gitdc16f8c.fc25.x86_64        @updates-testing
    Install  libglvnd-opengl-1:0.2.999-7.gitdc16f8c.fc25.x86_64     @updates-testing
No package mesa-libGL-0:13.0.3-1.fc25.x86_64 available.
Error: An operation cannot be undone

Do you know how to fix it?

Comment 25 Gurenko Alex 2017-01-31 10:03:03 UTC
 @David Novák Right, I have keepcache=True in my dnf.conf, so that's why it worked for me. Maybe downgrading/forcing other package version will work? 13.0.3-1 was really removed from all repos.
 You should be able to see available versions by doing dnf --showduplicates list mesa-libGL

Comment 26 Igor Gnatenko 2017-01-31 10:08:33 UTC
*** Bug 1417793 has been marked as a duplicate of this bug. ***

Comment 27 David Novák 2017-01-31 10:16:35 UTC
(In reply to Gurenko Alex from comment #25)
>  @David Novák Right, I have keepcache=True in my dnf.conf, so that's why it
> worked for me. Maybe downgrading/forcing other package version will work?
> 13.0.3-1 was really removed from all repos.
>  You should be able to see available versions by doing dnf --showduplicates
> list mesa-libGL

Installed Packages
mesa-libGL.i686                       13.0.3-4.fc25                     @updates
mesa-libGL.x86_64                     13.0.3-4.fc25                     @updates
Available Packages
mesa-libGL.i686                       12.0.3-3.fc25                     fedora  
mesa-libGL.x86_64                     12.0.3-3.fc25                     fedora  
mesa-libGL.i686                       13.0.3-4.fc25                     @updates
mesa-libGL.x86_64                     13.0.3-4.fc25                     @updates
mesa-libGL.i686                       13.0.3-5.fc25                     updates 
mesa-libGL.x86_64                     13.0.3-5.fc25                     updates 

I'd have to downgrade back to mesa 12..

Can I get rid of the packages from updates-testing somehow?

When I tried "dnf remove libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.x86_64", it wanted to remove basically everything (6 GB of packages).

Comment 28 David Novák 2017-01-31 10:22:14 UTC
OK, I fixed it by running:
dnf repository-packages updates-testing remove 

It automatically did update corresponding mesa libs..

Upgrading:
 mesa-libEGL         i686   13.0.3-5.fc25                updates          102 k
 mesa-libEGL         x86_64 13.0.3-5.fc25                updates          101 k
 mesa-libEGL-devel   x86_64 13.0.3-5.fc25                updates           39 k
 mesa-libGL          i686   13.0.3-5.fc25                updates          179 k
 mesa-libGL          x86_64 13.0.3-5.fc25                updates          163 k
 mesa-libGL-devel    x86_64 13.0.3-5.fc25                updates          162 k
 mesa-libGLES        x86_64 13.0.3-5.fc25                updates           33 k
 mesa-libglapi       i686   13.0.3-5.fc25                updates           59 k
 mesa-libglapi       x86_64 13.0.3-5.fc25                updates           49 k
Removing:
 libglvnd            i686   1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 357 k
 libglvnd            x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 649 k
 libglvnd-core-devel x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing  39 k
 libglvnd-devel      x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing   0  
 libglvnd-egl        i686   1:0.2.999-7.gitdc16f8c.fc25  @updates-testing  77 k
 libglvnd-egl        x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing  77 k
 libglvnd-gles       x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 101 k
 libglvnd-glx        i686   1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 467 k
 libglvnd-glx        x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 637 k
 libglvnd-opengl     x86_64 1:0.2.999-7.gitdc16f8c.fc25  @updates-testing 197 k

Comment 29 Gurenko Alex 2017-01-31 10:29:38 UTC
(In reply to David Novák from comment #28)
> OK, I fixed it by running:
> dnf repository-packages updates-testing remove 
> 
> It automatically did update corresponding mesa libs..

Glad it worked :)

Comment 30 Kalev Lember 2017-01-31 11:23:00 UTC
(In reply to Paul DeStefano from comment #23)
> I don't think the issue is closed.
> 
> The error reported here is that packages were published that made it to
> updates that were broken *beyond* what DNF could handle.  That's this bug
> and nothing in the bug suggests it was fixed.  Publishing a fixed package is
> good, but, that's not the root cause of this bug.

This should be fixed now.

We had a bit of a coordination issue where a mesa -4 build with libglvnd support got pushed to stable before it was supposed to (without a matching libglvnd build) and caused broken dependencies.

We've now tried to address this in two steps:

1) For people who don't have updates-testing enabled, mesa -5 build that got pushed to stable last night reverts the libglvnd support, making the stable updates stream properly installable again and self-contained

2) For people who use updates-testing, there's a new mesa -6 build in updates-testing that continues offering the libglvnd support

This should fix update issues for most people, especially those who waited for the broken deps to resolve itself.

For those who _temporarily_ enabled the updates-testing repo and already got libglvnd, I would recommend continuing to use the mesa and libglvnd from updates-testing repo (dnf update --enablerepo updates-testing 'mesa*').

Sorry for the mess. https://pagure.io/fesco/issue/1675 has some background info if you want to read up on this.

Comment 31 Nate Graham 2017-01-31 15:37:38 UTC
`dnf repository-packages updates-testing remove` isn't working for me:

$ sudo dnf repository-packages updates-testing remove
[sudo] password for nate: 
Last metadata expiration check: 0:48:18 ago on Tue Jan 31 07:45:22 2017.
Error: package ffmpeg-libs-3.1.5-1.fc25.x86_64 requires libva-x11.so.1()(64bit), but none of the providers can be installed.
package sssd-common-1.14.2-2.fc25.x86_64 requires libhttp_parser_strict.so.2()(64bit), but none of the providers can be installed.
package java-1.8.0-openjdk-headless-1:1.8.0.121-1.b14.fc25.x86_64 requires javapackages-tools, but none of the providers can be installed.
package webkitgtk4-plugin-process-gtk2-2.14.3-1.fc25.x86_64 requires libicuuc.so.57()(64bit), but none of the providers can be installed.
package libvirt-daemon-driver-storage-2.2.0-2.fc25.x86_64 requires nfs-utils, but none of the providers can be installed.
package deja-dup-34.3-1.fc25.x86_64 requires python-gobject-base, but none of the providers can be installed.
package gnome-shell-3.22.2-2.fc25.x86_64 requires switcheroo-control, but none of the providers can be installed.
package javapackages-tools-4.7.0-6.1.fc25.noarch requires python3-javapackages = 4.7.0-6.1.fc25, but none of the providers can be installed
(try to add '--allowerasing' to command line to replace conflicting packages)



But sticking with getting mesa from the updates-testing repo isn't working either:

$ sudo dnf update --refresh
google-chrome                                                             31 kB/s | 3.7 kB     00:00    
Fedora 25 openh264 (From Cisco) - x86_64                                  16 kB/s | 3.0 kB     00:00    
SpiderOakONE Stable Distribution                                          32 kB/s | 4.2 kB     00:00    
Dependencies resolved.
=========================================================================================================
 Package                             Arch             Version                    Repository         Size
=========================================================================================================
Upgrading:
 mesa-dri-drivers                    i686             13.0.3-5.fc25              updates            12 M
 mesa-dri-drivers                    x86_64           13.0.3-5.fc25              updates            11 M
 mesa-filesystem                     i686             13.0.3-5.fc25              updates            24 k
 mesa-filesystem                     x86_64           13.0.3-5.fc25              updates            24 k
 mesa-libEGL                         i686             13.0.3-5.fc25              updates           102 k
 mesa-libEGL                         x86_64           13.0.3-5.fc25              updates           101 k
 mesa-libEGL-devel                   x86_64           13.0.3-5.fc25              updates            39 k
 mesa-libGL                          i686             13.0.3-5.fc25              updates           179 k
 mesa-libGL                          x86_64           13.0.3-5.fc25              updates           163 k
 mesa-libGL-devel                    x86_64           13.0.3-5.fc25              updates           162 k
 mesa-libGLES                        x86_64           13.0.3-5.fc25              updates            33 k
 mesa-libGLES-devel                  x86_64           13.0.3-5.fc25              updates            62 k
 mesa-libgbm                         i686             13.0.3-5.fc25              updates            43 k
 mesa-libgbm                         x86_64           13.0.3-5.fc25              updates            42 k
 mesa-libglapi                       i686             13.0.3-5.fc25              updates            59 k
 mesa-libglapi                       x86_64           13.0.3-5.fc25              updates            49 k
 mesa-libwayland-egl                 x86_64           13.0.3-5.fc25              updates            25 k
 mesa-libwayland-egl-devel           x86_64           13.0.3-5.fc25              updates            22 k
 mesa-libxatracker                   x86_64           13.0.3-5.fc25              updates           1.4 M
 nfs-utils                           x86_64           1:2.1.1-1.fc25             updates           393 k

Transaction Summary
=========================================================================================================
Upgrade  20 Packages

Total download size: 26 M
Is this ok [y/N]: y
Downloading Packages:
(1/20): mesa-libEGL-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm              107 kB/s |  37 kB     00:00    
(2/20): mesa-libEGL-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm                240 kB/s |  35 kB     00:00    
[DRPM] mesa-libEGL-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                        
(3/20): mesa-dri-drivers-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm           943 kB/s | 603 kB     00:00    
[DRPM] mesa-libEGL-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm: done                                          
(4/20): mesa-libGL-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm               364 kB/s |  63 kB     00:00    
(5/20): mesa-dri-drivers-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm         920 kB/s | 652 kB     00:00    
(6/20): mesa-libglapi-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm            169 kB/s |  20 kB     00:00    
(7/20): mesa-libGL-devel-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm         164 kB/s |  21 kB     00:00    
[DRPM] mesa-libGL-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                         
[DRPM] mesa-libglapi-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                      
(8/20): mesa-libGL-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm                 567 kB/s |  63 kB     00:00    
(9/20): mesa-libglapi-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm              162 kB/s |  20 kB     00:00    
(10/20): mesa-libGLES-devel-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm      159 kB/s |  21 kB     00:00    
(11/20): mesa-libgbm-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm             157 kB/s |  20 kB     00:00    
(12/20): mesa-libgbm-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm               167 kB/s |  20 kB     00:00    
[DRPM] mesa-libGL-devel-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                   
[DRPM] mesa-libGL-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm: done                                           
(13/20): mesa-libxatracker-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm       173 kB/s |  20 kB     00:00    
[DRPM] mesa-libglapi-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm: done                                        
(14/20): mesa-filesystem-13.0.3-5.fc25.x86_64.rpm                        192 kB/s |  24 kB     00:00    
(15/20): mesa-filesystem-13.0.3-5.fc25.i686.rpm                          238 kB/s |  24 kB     00:00    
(16/20): mesa-libEGL-devel-13.0.3-5.fc25.x86_64.rpm                      311 kB/s |  39 kB     00:00    
(17/20): mesa-libGLES-13.0.3-5.fc25.x86_64.rpm                           232 kB/s |  33 kB     00:00    
(18/20): mesa-libwayland-egl-13.0.3-5.fc25.x86_64.rpm                    250 kB/s |  25 kB     00:00    
(19/20): mesa-libwayland-egl-devel-13.0.3-5.fc25.x86_64.rpm              159 kB/s |  22 kB     00:00    
(20/20): nfs-utils-2.1.1-1.fc25.x86_64.rpm                               2.3 MB/s | 393 kB     00:00    
[DRPM] mesa-libGLES-devel-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                 
[DRPM] mesa-libgbm-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                        
[DRPM] mesa-libgbm-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm: done                                          
[DRPM] mesa-libxatracker-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                  
[DRPM] mesa-dri-drivers-13.0.3-4.fc25_13.0.3-5.fc25.x86_64.drpm: done                                   
[DRPM] mesa-dri-drivers-13.0.3-4.fc25_13.0.3-5.fc25.i686.drpm: done                                     
---------------------------------------------------------------------------------------------------------
Total                                                                    211 kB/s | 2.1 MB     00:10     
Delta RPMs reduced 26.0 MB of updates to 2.1 MB (91.1% saved)
Running transaction check
Transaction check succeeded.
Running transaction test
The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Transaction check error:
  file /usr/lib64/libGL.so.1 from install of mesa-libGL-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-glx-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib64/libGLESv2.so.2.0.0 from install of mesa-libGLES-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-gles-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib64/libEGL.so.1.0.0 from install of mesa-libEGL-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib64/libGL.so from install of mesa-libGL-devel-13.0.3-5.fc25.x86_64 conflicts with file from package libglvnd-devel-1:0.2.999-7.gitdc16f8c.fc25.x86_64
  file /usr/lib/libGL.so.1 from install of mesa-libGL-13.0.3-5.fc25.i686 conflicts with file from package libglvnd-glx-1:0.2.999-7.gitdc16f8c.fc25.i686
  file /usr/lib/libEGL.so.1.0.0 from install of mesa-libEGL-13.0.3-5.fc25.i686 conflicts with file from package libglvnd-egl-1:0.2.999-7.gitdc16f8c.fc25.i686

Error Summary





This is a pretty sucky situation...

Comment 32 Nate Graham 2017-01-31 15:39:36 UTC
It's not just me, either: https://www.reddit.com/r/Fedora/comments/5r8t6w/mesa_conflicts_after_update_again/

Comment 33 Michal Jaegermann 2017-01-31 17:19:06 UTC
(In reply to Nate Graham from comment #31)
> `dnf repository-packages updates-testing remove` isn't working for me:
> 
> $ sudo dnf repository-packages updates-testing remove
....
> 
> Error Summary .... (with file conflicts)

With 'updates-testing' out of the way and mesa-3.0.3-5.fc25 packages already in 'update' repositories (check before proceeding with 'dnf list available | grep mesa') the following should work:

  rpm -e -v --nodeps 'libglvnd*'
  dnf update

If the above 'rpm' command is not enough add '--force' to options.  You may want to follow with 'dnf distro-sync' just to be sure that you do not have
any leftovers. You may possibly need to issue before doing all that, as root, 'telinit 3'

This is not tested but I do not see how this would not work based on a similar knots I bumped into in the past while hacking with 'rawhide'.

Comment 34 Gary Gatling 2017-01-31 17:59:25 UTC
mesa-13.0.3-6.fc25 from "updates-testing" breaks bumblebee on my test machine.

https://paste.fedoraproject.org/541714/85132148/

I notice a undefined symbol: _glapi_tls_Current in the output.

Any clues on how I can get it working again?

Comment 35 Kalev Lember 2017-01-31 18:55:25 UTC
(In reply to Gary Gatling from comment #34)
> mesa-13.0.3-6.fc25 from "updates-testing" breaks bumblebee on my test
> machine.
> 
> https://paste.fedoraproject.org/541714/85132148/
> 
> I notice a undefined symbol: _glapi_tls_Current in the output.
> 
> Any clues on how I can get it working again?

Can you file a separate bug about this, please?

Comment 36 Tomas Toth 2017-01-31 20:58:16 UTC
The following worked for me:
# dnf repository-packages updates-testing remove --allowerasing
Last metadata expiration check: 1:17:30 ago on Tue Jan 31 20:35:53 2017.
Dependencies resolved.
====================================================================================
 Package          Arch      Version			  Repository	       Size
====================================================================================
Upgrading:
 mesa-libEGL      x86_64    13.0.3-5.fc25		  updates	      101 k
 mesa-libGL       x86_64    13.0.3-5.fc25		  updates	      163 k
 mesa-libGLES     x86_64    13.0.3-5.fc25		  updates	       33 k
 mesa-libOSMesa   x86_64    13.0.3-5.fc25		  updates	      1.9 M
 mesa-libglapi    x86_64    13.0.3-5.fc25		  updates	       49 k
Removing:
 libglvnd         x86_64    1:0.2.999-7.gitdc16f8c.fc25   @updates-testing    649 k
 libglvnd-egl     x86_64    1:0.2.999-7.gitdc16f8c.fc25   @updates-testing     77 k
 libglvnd-gles    x86_64    1:0.2.999-7.gitdc16f8c.fc25   @updates-testing    101 k
 libglvnd-glx     x86_64    1:0.2.999-7.gitdc16f8c.fc25   @updates-testing    637 k

Transaction Summary
====================================================================================
Upgrade  5 Packages
Remove   4 Packages
 . . . .

Comment 37 Gary Gatling 2017-01-31 21:24:15 UTC
(In reply to Kalev Lember from comment #35)
> (In reply to Gary Gatling from comment #34)
> > mesa-13.0.3-6.fc25 from "updates-testing" breaks bumblebee on my test
> > machine.
> > 
> > https://paste.fedoraproject.org/541714/85132148/
> > 
> > I notice a undefined symbol: _glapi_tls_Current in the output.
> > 
> > Any clues on how I can get it working again?
> 
> Can you file a separate bug about this, please?

Sure. Thanks. opened https://bugzilla.redhat.com/show_bug.cgi?id=1418103

Comment 38 Paul DeStefano 2017-01-31 23:26:48 UTC
@Kalev Lember, thank you!  I think that's an excellent response; much appreciated.  And thanks for the background details; I'm interested in that stuff.  Many thanks.


Note You need to log in before you can comment on or make changes to this bug.