Bug 1417540 - Mark tests/bitrot/bug-1373520.t bad
Summary: Mark tests/bitrot/bug-1373520.t bad
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Atin Mukherjee
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1419696
TreeView+ depends on / blocked
 
Reported: 2017-01-30 07:42 UTC by Atin Mukherjee
Modified: 2017-05-30 18:40 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.11.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-05-30 18:40:10 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Atin Mukherjee 2017-01-30 07:42:16 UTC
Description of problem:

The test mentioned in summary is now failing frequently, to unblock the other patches mark it bad for now.

Regression failure links:

https://build.gluster.org/job/centos6-regression/2934/console
https://build.gluster.org/job/centos6-regression/2911/console

Comment 1 Worker Ant 2017-01-30 07:44:16 UTC
REVIEW: https://review.gluster.org/16479 (tests: Mark tests/bitrot/bug-1373520.t bad) posted (#1) for review on master by Atin Mukherjee (amukherj@redhat.com)

Comment 2 Worker Ant 2017-01-30 13:46:05 UTC
COMMIT: https://review.gluster.org/16479 committed in master by Jeff Darcy (jdarcy@redhat.com) 
------
commit faf43235e0b3308388d0146e65b3982c11661db0
Author: Atin Mukherjee <amukherj@redhat.com>
Date:   Mon Jan 30 13:13:54 2017 +0530

    tests: Mark tests/bitrot/bug-1373520.t bad
    
    Change-Id: Ief8014dd9faa012c7f3c5347f597a155873a8f92
    BUG: 1417540
    Signed-off-by: Atin Mukherjee <amukherj@redhat.com>
    Reviewed-on: https://review.gluster.org/16479
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: N Balachandran <nbalacha@redhat.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Kotresh HR <khiremat@redhat.com>
    Reviewed-by: Jeff Darcy <jdarcy@redhat.com>

Comment 3 Shyamsundar 2017-02-06 19:04:28 UTC
Although this bug is tracked against mainline, I backported the commit to mark this test as bad in release-3.10 as well. This is to ensure we do not get spurious failures against commits for that branch.

The Bug used to make this change is #1419696

Request any fix to be back ported and the test unblocked as appropriate.

Comment 4 Shyamsundar 2017-05-30 18:40:10 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.11.0, please open a new bug report.

glusterfs-3.11.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2017-May/000073.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.