Bug 1419696 - Fix spurious failure of ec-background-heal.t and tests/bitrot/bug-1373520.t
Summary: Fix spurious failure of ec-background-heal.t and tests/bitrot/bug-1373520.t
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: tests
Version: 3.10
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Shyamsundar
QA Contact:
URL:
Whiteboard:
Depends On: 1416689 1417540
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 19:02 UTC by Shyamsundar
Modified: 2017-03-06 17:45 UTC (History)
1 user (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 17:45:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Shyamsundar 2017-02-06 19:02:33 UTC
Description of problem:
Marking the 2 said tests in Summary as bad in release-3.10 to prevent spurious failures.

The mainline bugs for the same are #1416689 and #1417540

Fixes for the test case should consider back porting the said fixes to release-3.10 as well, if applicable, or if not remove the bad test lines as appropriate.

Comment 1 Worker Ant 2017-02-06 19:08:02 UTC
REVIEW: https://review.gluster.org/16549 (tests: Marked 2 tests in master that bad, the same in release-3.10) posted (#1) for review on release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com)

Comment 2 Worker Ant 2017-02-07 13:30:08 UTC
COMMIT: https://review.gluster.org/16549 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 7633e44854001ba9378320501b99dbe027dcc63c
Author: Shyam <srangana@redhat.com>
Date:   Mon Feb 6 14:05:54 2017 -0500

    tests: Marked 2 tests in master that bad, the same in release-3.10
    
    The 2 tests that were marked bad in master are,
    tests/basic/ec/ec-background-heals.t
    tests/bitrot/bug-1373520.t
    
    The same are marked bad in release-3.10 to prevent any spurious
    failures during backporting other commits.
    
    When the failures are analyzed and fixed in master the same would
    need to be backported, as applicable, to release-3.10 branch.
    
    Change-Id: I7d686bc90e1ee443475d3a3512fa7dfb7cbeede7
    BUG: 1419696
    Signed-off-by: Shyam <srangana@redhat.com>
    Reviewed-on: https://review.gluster.org/16549
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Atin Mukherjee <amukherj@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:45:31 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.