Bug 1417554 - Mount options are not explicitly made visible, when the new storage domain is associated with gluster volume
Summary: Mount options are not explicitly made visible, when the new storage domain is...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Gluster
Version: 4.1.0
Hardware: x86_64
OS: Linux
medium
medium vote
Target Milestone: ovirt-4.1.1-1
: 4.1.1.6
Assignee: Sahina Bose
QA Contact: SATHEESARAN
URL:
Whiteboard:
Depends On:
Blocks: Gluster-HC-2
TreeView+ depends on / blocked
 
Reported: 2017-01-30 09:14 UTC by SATHEESARAN
Modified: 2017-04-21 09:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-04-21 09:36:00 UTC
oVirt Team: Gluster
rule-engine: ovirt-4.1+
rule-engine: planning_ack+
sabose: devel_ack+
sasundar: testing_ack+


Attachments (Terms of Use)
screenshot showing that mount options are not populated (167.99 KB, image/png)
2017-04-07 07:05 UTC, SATHEESARAN
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 72293 master MERGED webadmin: Update backup servers option 2017-02-21 13:06:21 UTC
oVirt gerrit 72770 ovirt-engine-4.1 MERGED webadmin: Update backup servers option 2017-02-21 17:04:51 UTC

Description SATHEESARAN 2017-01-30 09:14:50 UTC
Description of problem:
-----------------------
While creating a new gluster backed data domain, there is checkbox provided with the name 'use managed gluster volume', which lists the gluster volume that is managed with that oVirt, to be used for that data domain.

But this also fills the mount options which is not actually visible, unless I chose to manage the domain( by clicking 'manage domain' )post its creation

Version-Release number of selected component (if applicable):
-------------------------------------------------------------
https://bugzilla.redhat.com/show_bug.cgi?id=1417545

How reproducible:
-----------------
Always

Steps to Reproduce:
-------------------
1. Create a cluster with virt + gluster capability enabled
2. Add 3 nodes and create a replica 3 volume, optimize for virt store
3. Now create a new gluster data domain and select 'use managed gluster volume' which will the list the gluster volumes managed in that cluster
4. Choose a gluster volume from the dropdown list

Actual results:
---------------
Mount options are not really visible, although its computed
Click on 'Manage domain' and you can see the mount options are populated

Expected results:
-----------------
Mount options should be displayed immediately on the text column, immediately its been computed after choosing that particular volume

Comment 1 Sahina Bose 2017-02-10 09:39:41 UTC
Moving to 4.1.1 as there's a problem in flow when storage domain is added with only of the hosts of volume added to cluster.

Comment 2 SATHEESARAN 2017-03-09 06:35:29 UTC
Tested with RHV 4.1.1.4 and I see that while creating the gluster domain, the mount options are still not made visible and also when explicitly added mount options are also not visible while selecting 'manage domain'

Comment 3 Red Hat Bugzilla Rules Engine 2017-03-09 06:35:33 UTC
Target release should be placed once a package build is known to fix a issue. Since this bug is not modified, the target version has been reset. Please use target milestone to plan a fix for a oVirt release.

Comment 4 Sahina Bose 2017-03-09 07:12:39 UTC
I see that the mount options are shown when the bricks are listed for the gluster volume.
Can you recheck based on this:

1. backup-volfile-servers is auto-populated if oVirt engine is aware of the additional brick/servers associated with gluster volume
2. The ip address is picked if a gluster network is available and associated with an interface on host. Otherwise hostname is used

Comment 5 SATHEESARAN 2017-03-09 07:27:40 UTC
(In reply to Sahina Bose from comment #4)
> I see that the mount options are shown when the bricks are listed for the
> gluster volume.
> Can you recheck based on this:
> 
> 1. backup-volfile-servers is auto-populated if oVirt engine is aware of the
> additional brick/servers associated with gluster volume
> 2. The ip address is picked if a gluster network is available and associated
> with an interface on host. Otherwise hostname is used

Sahina,

The problem is when the master storage domain is created.

With HC deployment, there will be only one host at the very beginning. 

When creating the master storage domain, the backup-volfile-servers can't be computed and we seek that value as the input from the user.

When I input those values, I couldn't see the values after the master storage domain creation, though the values are persisted in the DB

Also after adding 2 more hosts, I could see that UI is picking up those 2 machines' IP for backup-volfile-servers, but not showing the initial values that I gave as mount options

Comment 6 SATHEESARAN 2017-03-09 07:28:48 UTC
The bug solves the issue for new storage domain creation after adding 2 more hosts to the cluster. In that case, mount options ( backup-volfile-servers ) are correctly populated.

Comment 7 Sahina Bose 2017-03-14 13:51:02 UTC
I could not reproduce this. I had a 3 node setup, and I created a storage domain and manually entered mount options. It was both persisted and shown in the UI. will retry this.

Moving it to 4.1.2 as this is not a blocker - the main flow works.

Comment 8 SATHEESARAN 2017-03-21 10:42:03 UTC
(In reply to Sahina Bose from comment #7)
> I could not reproduce this. I had a 3 node setup, and I created a storage
> domain and manually entered mount options. It was both persisted and shown
> in the UI. will retry this.
> 
> Moving it to 4.1.2 as this is not a blocker - the main flow works.

Sahina,

I have got it confirmed from Kasturi that the mount options are reflected correctly in RHV UI and tested with the latest RHV-4.1.1-4

Could you please target this bug for ovirt-4.1.1 and move this bug to ON_QA for verification ?

Comment 9 SATHEESARAN 2017-04-07 07:03:58 UTC
I am still ** not ** seeing the mount options seen in the RHV UI, when only one host is available.

Test steps are as follows :
1. Deploy HE with sharded replica Create virt + gluster cluster
2. Once HE is deployed, create storage domain from UI and provide mount options
3. HE SD will get imported automatically

In this state, check for mount options of master storage domain. It looks empty.

Is this expected ?

Comment 10 SATHEESARAN 2017-04-07 07:05:19 UTC
Created attachment 1269583 [details]
screenshot showing that mount options are not populated

Comment 11 SATHEESARAN 2017-04-07 07:50:29 UTC
Verified with RHV-4.1.1-8

The problem is seen when there is only one host in the cluster and one master SD created, the mount options are not seen while clicking on 'Manage domain'


Once all the additional hosts in the gluster cluster are added to the host through RHV UI, the mount options is shown correctly

Comment 12 Sahina Bose 2017-04-17 08:21:52 UTC
(In reply to SATHEESARAN from comment #9)
> I am still ** not ** seeing the mount options seen in the RHV UI, when only
> one host is available.
> 
> Test steps are as follows :
> 1. Deploy HE with sharded replica Create virt + gluster cluster
> 2. Once HE is deployed, create storage domain from UI and provide mount
> options
> 3. HE SD will get imported automatically
> 
> In this state, check for mount options of master storage domain. It looks
> empty.
> 
> Is this expected ?

No, not expected. can you log a separate bz for this?


Note You need to log in before you can comment on or make changes to this bug.