Bug 1417802 - debug/trace: Print iatts of individual entries in readdirp callback for better debugging experience
Summary: debug/trace: Print iatts of individual entries in readdirp callback for bette...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: trace
Version: 3.8
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1415560 1417803 1417804
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 05:50 UTC by Krutika Dhananjay
Modified: 2017-02-20 12:34 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.8.9
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1415560
Environment:
Last Closed: 2017-02-20 12:34:24 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2017-01-31 05:50:52 UTC
+++ This bug was initially created as a clone of Bug #1415560 +++

Description of problem:

Print iatts of individual entries in readdirp callback for better debugging experience.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from hari gowtham on 2017-01-24 07:32:09 EST ---

Hi Krutika, I see that the subject of the bug is sort of self explanatory, still it would be better if you can fill up the description for other to have a better understanding. 
Thanks.

--- Additional comment from Krutika Dhananjay on 2017-01-31 00:50:08 EST ---

https://review.gluster.org/#/c/16453/

Comment 1 Worker Ant 2017-01-31 05:51:20 UTC
REVIEW: https://review.gluster.org/16482 (debug/trace: Print entries' iatts in readdirp cbk) posted (#1) for review on release-3.8 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2017-02-01 04:18:09 UTC
REVIEW: https://review.gluster.org/16482 (debug/trace: Print entries' iatts in readdirp cbk) posted (#2) for review on release-3.8 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 3 Worker Ant 2017-02-06 08:54:11 UTC
COMMIT: https://review.gluster.org/16482 committed in release-3.8 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 7c242cacf578c18b1c9131771567a17e18b4b369
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jan 9 12:45:36 2017 +0530

    debug/trace: Print entries' iatts in readdirp cbk
    
            Backport of: http://review.gluster.org/16432
    
    Change-Id: Ie96b04e7961d353f2a193f368ac5ae94a3f64d77
    BUG: 1417802
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/16482
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>

Comment 4 Niels de Vos 2017-02-20 12:34:24 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.9, please open a new bug report.

glusterfs-3.8.9 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://lists.gluster.org/pipermail/announce/2017-February/000066.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.