Bug 1417804 - debug/trace: Print iatts of individual entries in readdirp callback for better debugging experience
Summary: debug/trace: Print iatts of individual entries in readdirp callback for bette...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: trace
Version: 3.10
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On: 1415560
Blocks: 1417802 1417803
TreeView+ depends on / blocked
 
Reported: 2017-01-31 05:54 UTC by Krutika Dhananjay
Modified: 2017-03-06 17:44 UTC (History)
2 users (show)

Fixed In Version: glusterfs-3.10.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1415560
Environment:
Last Closed: 2017-03-06 17:44:58 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Krutika Dhananjay 2017-01-31 05:54:58 UTC
+++ This bug was initially created as a clone of Bug #1415560 +++

Description of problem:

Print iatts of individual entries in readdirp callback for better debugging experience

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from hari gowtham on 2017-01-24 07:32:09 EST ---

Hi Krutika, I see that the subject of the bug is sort of self explanatory, still it would be better if you can fill up the description for other to have a better understanding. 
Thanks.

--- Additional comment from Krutika Dhananjay on 2017-01-31 00:50:08 EST ---

https://review.gluster.org/#/c/16453/

Comment 1 Worker Ant 2017-01-31 05:55:16 UTC
REVIEW: https://review.gluster.org/16484 (debug/trace: Print entries' iatts in readdirp cbk) posted (#1) for review on release-3.10 by Krutika Dhananjay (kdhananj@redhat.com)

Comment 2 Worker Ant 2017-01-31 13:59:33 UTC
COMMIT: https://review.gluster.org/16484 committed in release-3.10 by Shyamsundar Ranganathan (srangana@redhat.com) 
------
commit 2a1a97cbdfea9ccdbad194c4b1cca4041bd82ec0
Author: Krutika Dhananjay <kdhananj@redhat.com>
Date:   Mon Jan 9 12:45:36 2017 +0530

    debug/trace: Print entries' iatts in readdirp cbk
    
            Backport of: http://review.gluster.org/16432
    
    Change-Id: I09d0c34918299626f0a2c58c8f864f2a0dbd0ff2
    BUG: 1417804
    Signed-off-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-on: https://review.gluster.org/16484
    Smoke: Gluster Build System <jenkins@build.gluster.org>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.org>
    Reviewed-by: Shyamsundar Ranganathan <srangana@redhat.com>

Comment 3 Shyamsundar 2017-03-06 17:44:58 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.10.0, please open a new bug report.

glusterfs-3.10.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/gluster-users/2017-February/030119.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.