Bug 1417897 - UI: Network provider "Timelines" button not working
Summary: UI: Network provider "Timelines" button not working
Keywords:
Status: CLOSED DUPLICATE of bug 1419908
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.7.0
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: GA
: cfme-future
Assignee: Roman Blanco
QA Contact: Niyaz Akhtar Ansari
URL:
Whiteboard: ui:timeline
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 11:30 UTC by Niyaz Akhtar Ansari
Modified: 2017-02-20 14:56 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-02-20 14:56:40 UTC
Category: Bug
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
screenshot (14.19 KB, image/png)
2017-01-31 11:30 UTC, Niyaz Akhtar Ansari
no flags Details

Description Niyaz Akhtar Ansari 2017-01-31 11:30:07 UTC
Created attachment 1246193 [details]
screenshot

Description of problem:


Version-Release number of selected component (if applicable):
Version 5.7.1.0.20170124142149_8a5f4d5 

How reproducible:
100%

Steps to Reproduce:
1.Add RHOS provider
2.Navigate to Networks -> Provider
3.Go to Network provider summary page
4.From Monitoring tab click on Timelines

Actual results:
After clicking on timelines it is showing "The page you were looking for doesn't exist." 

Expected results:


Additional info:

Production Log:
[----] I, [2017-01-31T06:23:58.593876 #2984:dc7184] INFO -- : Started GET "/ems_network/show/4?display=timeline" for 127.0.0.1 at 2017-01-31 06:23:58 -0500
[----] F, [2017-01-31T06:23:58.605225 #2984:dc7184] FATAL -- : 
[----] F, [2017-01-31T06:23:58.605308 #2984:dc7184] FATAL -- : ActionController::RoutingError (No route matches [GET] "/ems_network/show/4"):
[----] F, [2017-01-31T06:23:58.605336 #2984:dc7184] FATAL -- : 
[----] F, [2017-01-31T06:23:58.605360 #2984:dc7184] FATAL -- : actionpack (5.0.0.1) lib/action_dispatch/middleware/debug_exceptions.rb:53:in `call'
[----] F, [2017-01-31T06:23:58.605381 #2984:dc7184] FATAL -- : actionpack (5.0.0.1) lib/action_dispatch/middleware/show_exceptions.rb:31:in `call'
[----] F, [2017-01-31T06:23:58.605438 #2984:dc7184] FATAL -- : railties (5.0.0.1) lib/rails/rack/logger.rb:36:in `call_app'
[----] F, [2017-01-31T06:23:58.605460 #2984:dc7184] FATAL -- : railties (5.0.0.1) lib/rails/rack/logger.rb:26:in `call'
[----] F, [2017-01-31T06:23:58.605478 #2984:dc7184] FATAL -- : request_store (1.3.2) lib/request_store/middleware.rb:9:in `call'
[----] F, [2017-01-31T06:23:58.605510 #2984:dc7184] FATAL -- : actionpack (5.0.0.1) lib/action_dispatch/middleware/request_id.rb:24:in `call'
[----] F, [2017-01-31T06:23:58.605529 #2984:dc7184] FATAL -- : rack (2.0.1) lib/rack/method_override.rb:22:in `call'
[----] F, [2017-01-31T06:23:58.605546 #2984:dc7184] FATAL -- : rack (2.0.1) lib/rack/runtime.rb:22:in `call'
[----] F, [2017-01-31T06:23:58.605564 #2984:dc7184] FATAL -- : activesupport (5.0.0.1) lib/active_support/cache/strategy/local_cache_middleware.rb:28:in `call'
[----] F, [2017-01-31T06:23:58.605596 #2984:dc7184] FATAL -- : actionpack (5.0.0.1) lib/action_dispatch/middleware/executor.rb:12:in `call'
[----] F, [2017-01-31T06:23:58.605624 #2984:dc7184] FATAL -- : rack (2.0.1) lib/rack/sendfile.rb:111:in `call'
[----] F, [2017-01-31T06:23:58.605648 #2984:dc7184] FATAL -- : railties (5.0.0.1) lib/rails/engine.rb:522:in `call'
[----] F, [2017-01-31T06:23:58.605671 #2984:dc7184] FATAL -- : puma (3.3.0) lib/puma/configuration.rb:224:in `call'
[----] F, [2017-01-31T06:23:58.605694 #2984:dc7184] FATAL -- : puma (3.3.0) lib/puma/server.rb:561:in `handle_request'
[----] F, [2017-01-31T06:23:58.605715 #2984:dc7184] FATAL -- : puma (3.3.0) lib/puma/server.rb:406:in `process_client'
[----] F, [2017-01-31T06:23:58.605752 #2984:dc7184] FATAL -- : puma (3.3.0) lib/puma/server.rb:271:in `block in run'
[----] F, [2017-01-31T06:23:58.605789 #2984:dc7184] FATAL -- : puma (3.3.0) lib/puma/thread_pool.rb:111:in `block in spawn_thread'

Comment 4 Roman Blanco 2017-02-20 14:56:40 UTC
This BZ is a duplicate, issue is already fixed in master

*** This bug has been marked as a duplicate of bug 1419908 ***


Note You need to log in before you can comment on or make changes to this bug.