Bug 1418084 - paramiko throws "ValueError" when used with python2-crypto.x86_64 2.6.1-13.fc24
Summary: paramiko throws "ValueError" when used with python2-crypto.x86_64 2.6.1-13.fc24
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: python-paramiko
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1419299 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-01-31 19:25 UTC by Gal Ben Haim
Modified: 2017-02-08 08:16 UTC (History)
9 users (show)

Fixed In Version: python-paramiko-2.1.1-2.fc24
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1419312 1419640 (view as bug list)
Environment:
Last Closed: 2017-02-06 01:49:07 UTC
Type: Bug


Attachments (Terms of Use)

Description Gal Ben Haim 2017-01-31 19:25:57 UTC
Description of problem:

The latest release of python2-crypto.x86_64 2.6.1-13.fc24 breaks python2-paramiko.noarch 1.16.0-1.fc24 with the following error:

14:54:47 #   File "/usr/lib/python2.7/site-packages/paramiko/client.py", line 325, in connect
14:54:47 #     t.start_client()
14:54:47 #   File "/usr/lib/python2.7/site-packages/paramiko/transport.py", line 492, in start_client
14:54:47 #     raise e
14:54:47 # ValueError: CTR mode needs counter parameter, not IV


It seems like the changes in https://src.fedoraproject.org/cgit/rpms/python-crypto.git/commit/?id=c1648a020baecf519ed84c9db766a9f102564ce5 are the cause of the problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Nadav Goldin 2017-01-31 19:36:35 UTC
One nice solution would be to provide paramiko v2.x RPM(which is already available in fc25) to fc24. paramiko v2.x does not depend on python2-crypto.

Comment 2 Fedora Update System 2017-02-02 09:50:15 UTC
python-paramiko-2.1.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6bf7d0c531

Comment 3 Fedora Update System 2017-02-02 21:50:06 UTC
python-paramiko-2.1.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6bf7d0c531

Comment 4 Fedora Update System 2017-02-06 01:49:07 UTC
python-paramiko-2.1.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 5 Paul Howarth 2017-02-08 08:16:38 UTC
*** Bug 1419299 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.