Bug 1419640 - paramiko throws "ValueError" when used with python2-crypto.x86_64 2.6.1-13.fc24
Summary: paramiko throws "ValueError" when used with python2-crypto.x86_64 2.6.1-13.fc24
Keywords:
Status: CLOSED DUPLICATE of bug 1419312
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: python-paramiko
Version: epel7
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Jeffrey C. Ollie
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-02-06 15:54 UTC by Brian J. Murrell
Modified: 2017-02-06 18:16 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1418084
Environment:
Last Closed: 2017-02-06 18:16:11 UTC
Type: Bug


Attachments (Terms of Use)

Description Brian J. Murrell 2017-02-06 15:54:03 UTC
+++ This bug was initially created as a clone of Bug #1418084 +++

This seems to apply to EL7/EPEL7.  Should we solve it the same way?

Description of problem:

The latest release of python2-crypto.x86_64 2.6.1-13.fc24 breaks python2-paramiko.noarch 1.16.0-1.fc24 with the following error:

14:54:47 #   File "/usr/lib/python2.7/site-packages/paramiko/client.py", line 325, in connect
14:54:47 #     t.start_client()
14:54:47 #   File "/usr/lib/python2.7/site-packages/paramiko/transport.py", line 492, in start_client
14:54:47 #     raise e
14:54:47 # ValueError: CTR mode needs counter parameter, not IV


It seems like the changes in https://src.fedoraproject.org/cgit/rpms/python-crypto.git/commit/?id=c1648a020baecf519ed84c9db766a9f102564ce5 are the cause of the problem.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

--- Additional comment from Nadav Goldin on 2017-01-31 14:36:35 EST ---

One nice solution would be to provide paramiko v2.x RPM(which is already available in fc25) to fc24. paramiko v2.x does not depend on python2-crypto.

--- Additional comment from Fedora Update System on 2017-02-02 04:50:15 EST ---

python-paramiko-2.1.1-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2017-6bf7d0c531

--- Additional comment from Fedora Update System on 2017-02-02 16:50:06 EST ---

python-paramiko-2.1.1-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2017-6bf7d0c531

--- Additional comment from Fedora Update System on 2017-02-05 20:49:07 EST ---

python-paramiko-2.1.1-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 1 Igor Gnatenko 2017-02-06 18:16:11 UTC

*** This bug has been marked as a duplicate of bug 1419312 ***


Note You need to log in before you can comment on or make changes to this bug.