Bug 141830 - Script ignores /etc/alternatives/java
Summary: Script ignores /etc/alternatives/java
Status: CLOSED DUPLICATE of bug 141831
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse   
(Show other bugs)
Version: 2.0
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Aaron Luchko
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-03 22:49 UTC by Aaron Luchko
Modified: 2007-04-18 17:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 19:07:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aaron Luchko 2004-12-03 22:49:38 UTC
Description of problem: When the startup script attempts to autodetect
a jvm when none is supplied it uses IBM jvm even if BEA is set in
/etc/alternatives.  The problem lies in the lines

# Find our JVM.
if [ ! -x "$JAVACMD" -a -r /usr/share/java-utils/java-functions ]; then
  . /usr/share/java-utils/java-functions
  set_javacmd
fi

# Set JVM if -vm wasn't given.
if ! echo $@ | grep '\-vm ' >/dev/null 2>&1 && [ -n "$JAVACMD" ]; then
  ECLIPSE_OPTS="$ECLIPSE_OPTS -vm $JAVACMD"
fi

Comment 1 Aaron Luchko 2004-12-03 22:51:14 UTC
oops :)

*** This bug has been marked as a duplicate of 141831 ***

Comment 2 Red Hat Bugzilla 2006-02-21 19:07:30 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.