Bug 141831 - Script ignores /etc/alternatives/java
Summary: Script ignores /etc/alternatives/java
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse   
(Show other bugs)
Version: 2.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Aaron Luchko
QA Contact: eclipse-bugs
URL:
Whiteboard:
Keywords:
: 141830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-12-03 22:49 UTC by Aaron Luchko
Modified: 2007-04-18 17:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-17 18:41:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2005:214 normal SHIPPED_LIVE eclipse bug fix and enhancement update 2005-04-01 05:00:00 UTC

Description Aaron Luchko 2004-12-03 22:49:53 UTC
Description of problem: When the startup script attempts to autodetect
a jvm when none is supplied it uses IBM jvm even if BEA is set in
/etc/alternatives.  The problem lies in the lines

# Find our JVM.
if [ ! -x "$JAVACMD" -a -r /usr/share/java-utils/java-functions ]; then
  . /usr/share/java-utils/java-functions
  set_javacmd
fi

# Set JVM if -vm wasn't given.
if ! echo $@ | grep '\-vm ' >/dev/null 2>&1 && [ -n "$JAVACMD" ]; then
  ECLIPSE_OPTS="$ECLIPSE_OPTS -vm $JAVACMD"
fi

Comment 1 Aaron Luchko 2004-12-03 22:51:21 UTC
*** Bug 141830 has been marked as a duplicate of this bug. ***

Comment 2 Aaron Luchko 2005-01-17 18:41:07 UTC
Changed to use /usr/bin/java

Comment 3 David Lawrence 2005-04-01 23:30:16 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2005-214.html



Note You need to log in before you can comment on or make changes to this bug.