Bug 1418433 - [RFE] Containerized deployment of Manila service
Summary: [RFE] Containerized deployment of Manila service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
unspecified
Target Milestone: ga
: 12.0 (Pike)
Assignee: Victoria Martinez de la Cruz
QA Contact: Dustin Schoenbrun
URL:
Whiteboard:
Depends On:
Blocks: 1442136 1415556 1483694
TreeView+ depends on / blocked
 
Reported: 2017-02-01 20:01 UTC by Sean Cohen
Modified: 2018-02-05 19:04 UTC (History)
17 users (show)

Fixed In Version: openstack-tripleo-heat-templates-7.0.0-0.20170718190543.el7ost openstack-tripleo-common-7.3.1-0.20170718114623.1d79e16.el7ost
Doc Type: Technology Preview
Doc Text:
Containerized deployment of the OpenStack File Share Service (manila) is available as a technology preview in this release. By default, Manila, Cinder, and Neutron will still be deployed on bare metal machines.
Clone Of:
Environment:
Last Closed: 2017-12-13 21:06:26 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 449292 None None None 2017-04-25 16:09:59 UTC
OpenStack gerrit 453504 None None None 2017-06-14 09:06:31 UTC
OpenStack gerrit 455756 None None None 2017-04-25 16:10:21 UTC
OpenStack gerrit 471527 None None None 2017-06-12 18:56:57 UTC
Red Hat Product Errata RHEA-2017:3462 normal SHIPPED_LIVE Red Hat OpenStack Platform 12.0 Enhancement Advisory 2018-02-16 01:43:25 UTC

Description Sean Cohen 2017-02-01 20:01:53 UTC
Provide customers more stable, flexible, reliable and faster storage service deployments with more reliable and flexible lifecycle management and possibility to rollback when something goes wrong.

Comment 3 Christian Schwede (cschwede) 2017-04-24 13:38:31 UTC
Changing to ON_DEV - work already in progress.

Comment 9 Dan Prince 2017-07-21 19:15:38 UTC
The Manila share image is apparently not getting built for OSP12 yet. We added the image after the M2 upstream TripleO milestone here:

https://review.openstack.org/#/c/483920/

Could we get another ack on this so that downstream can start building this image.

Also, please CC jschluet@redhat.com so that he knows about the exception has been granted.

Comment 17 Dustin Schoenbrun 2017-12-06 14:23:48 UTC
We were able to successfully complete a full regression run against the NetApp cDOT Manila Driver when deployed in a containerized manner. Marking as verified.

Comment 20 errata-xmlrpc 2017-12-13 21:06:26 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3462


Note You need to log in before you can comment on or make changes to this bug.