Bug 1483694 - [RFE] Containerized deployment of Manila service
Summary: [RFE] Containerized deployment of Manila service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: Upstream M1
: 13.0 (Queens)
Assignee: Victoria Martinez de la Cruz
QA Contact: Dustin Schoenbrun
Don Domingo
URL:
Whiteboard:
Depends On: 1418433
Blocks: 1414980 1475544
TreeView+ depends on / blocked
 
Reported: 2017-08-21 18:34 UTC by Sean Cohen
Modified: 2018-06-27 13:34 UTC (History)
5 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:34:14 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 495370 None master: MERGED tripleo-heat-templates: Add storage backends env files for containerized deployment (I9886016b02bec26699af1f8165d7b0702d... 2018-02-07 14:16:52 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:34:53 UTC

Description Sean Cohen 2017-08-21 18:34:03 UTC
Provide customers more stable, flexible, reliable and faster storage service deployments with more reliable and flexible lifecycle management and possibility to rollback when something goes wrong.

Comment 1 Tom Barron 2017-09-09 12:06:46 UTC
495370 adds containerization for the manila backends and has merged to master so this feature is now testable in queens candidate code.

Comment 5 Vince Green 2018-05-29 14:10:03 UTC
Manila regression tests for OSP 13 passed.  Manila-ui plugin works but needed a workaround for the panel to load.  No issues with manila functionality, just needs packaging modification on the horizon container to load.

Results:
https://polarion.engineering.redhat.com/polarion/#/project/RHELOpenStackPlatform/testrun?id=20180523-1959&tab=records&result=passed

Manila-ui plugin workaround in:
https://bugzilla.redhat.com/show_bug.cgi?id=1578478

Marking RFE as verified.

Comment 7 errata-xmlrpc 2018-06-27 13:34:14 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.